summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-09-26 04:36:59 +0200
committerJakob Gahde2016-09-26 04:36:59 +0200
commitab290c0e35db4ce9d168916cd474292723f598df (patch)
treea67ef34d15222b3a629a9fdeec17cfea3b0362ec
parentaea4b7d89636cfff41088e80f08cbf802d7ec29c (diff)
downloadaur-ab290c0e35db4ce9d168916cd474292723f598df.tar.gz
lib32-directfb 1.7.7-1: New package
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD41
2 files changed, 39 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 641f40318a1c..0c202628a81a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
# Generated by mksrcinfo v8
-# Mon Sep 26 02:32:39 UTC 2016
-pkgbase = directfb
- pkgdesc = A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device
+# Mon Sep 26 02:36:12 UTC 2016
+pkgbase = lib32-directfb
+ pkgdesc = A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device (32-bit)
pkgver = 1.7.7
- pkgrel = 2
+ pkgrel = 1
url = http://www.directfb.org
- arch = i686
arch = x86_64
license = LGPL
- depends = gcc-libs
- depends = libjpeg
- depends = sdl
- depends = libpng
- depends = freetype2
- depends = libdrm
- depends = libgl
- depends = mesa
+ makedepends = gcc-multilib
+ depends = directfb
+ depends = lib32-gcc-libs
+ depends = lib32-libjpeg
+ depends = lib32-sdl
+ depends = lib32-libpng
+ depends = lib32-freetype2
+ depends = lib32-libdrm
+ depends = lib32-libgl
+ depends = lib32-mesa
source = http://sources.webos-ports.org/downloads/DirectFB-1.7.7.tar.gz
sha1sums = 205d824906906303db9b096cc2d3bea0662e8860
-pkgname = directfb
+pkgname = lib32-directfb
diff --git a/PKGBUILD b/PKGBUILD
index d00ece8db975..044a4c546a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
-# $Id$
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Eric Bélanger <eric@archlinux.org>
-pkgname=directfb
+_pkgname=directfb
+pkgname=lib32-${_pkgname}
pkgver=1.7.7
-pkgrel=2
-pkgdesc="A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device"
-arch=('i686' 'x86_64')
+pkgrel=1
+pkgdesc="A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device (32-bit)"
+arch=('x86_64')
url="http://www.directfb.org"
license=('LGPL')
-depends=('gcc-libs' 'libjpeg' 'sdl' 'libpng' 'freetype2' 'libdrm' 'libgl' 'mesa')
-#source=(http://www.directfb.org/downloads/Core/DirectFB-${pkgver%.*}/DirectFB-${pkgver}.tar.gz)
-source=(http://sources.webos-ports.org/downloads/DirectFB-$pkgver.tar.gz)
+depends=("${_pkgname}" 'lib32-gcc-libs' 'lib32-libjpeg' 'lib32-sdl' 'lib32-libpng' 'lib32-freetype2' 'lib32-libdrm' 'lib32-libgl' 'lib32-mesa')
+makedepends=('gcc-multilib')
+source=("http://sources.webos-ports.org/downloads/DirectFB-${pkgver}.tar.gz")
sha1sums=('205d824906906303db9b096cc2d3bea0662e8860')
build() {
- cd DirectFB-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc --enable-static \
- --enable-zlib --enable-x11 --enable-sdl --disable-vnc --disable-osx \
- --enable-video4linux2 --enable-voodoo \
- --enable-mesa --enable-drmkms
+ cd "${srcdir}/DirectFB-${pkgver}"
+
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./configure --prefix=/usr --libdir=/usr/lib32 --sysconfdir=/etc \
+ --enable-static --enable-zlib --enable-x11 --enable-sdl --disable-vnc \
+ --disable-osx --enable-video4linux2 --enable-voodoo --enable-mesa \
+ --enable-drmkms
make
-}
+}
package() {
- cd DirectFB-${pkgver}
+ cd "${srcdir}/DirectFB-${pkgver}"
+
make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/"{bin,include,share}
}