summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-12-15 09:36:50 -0500
committerAndrew Sun2020-12-15 09:36:50 -0500
commit9706c8031ef22ff476436d951c1161e819e64f65 (patch)
tree955a50545a1baefdd0ba118d17f60b60af53a716
parent8dc2e6c078cb6299bc75651e939c840ce3cef9c4 (diff)
downloadaur-9706c8031ef22ff476436d951c1161e819e64f65.tar.gz
1.1.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--glvnd.diff108
3 files changed, 6 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4f8e890525c..1a0a0f8f6f39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-egl-wayland
pkgdesc = EGLStream-based Wayland external platform (32-bit)
- pkgver = 1.1.5
+ pkgver = 1.1.6
pkgrel = 1
url = https://github.com/NVIDIA/egl-wayland
arch = x86_64
@@ -11,10 +11,8 @@ pkgbase = lib32-egl-wayland
depends = eglexternalplatform
depends = egl-wayland
options = !emptydirs
- source = git+https://github.com/NVIDIA/egl-wayland#commit=f08e1a570eee30cbaed4c49e761830667f5ba29e
- source = glvnd.diff
+ source = git+https://github.com/NVIDIA/egl-wayland#commit=1b0f2b8dd906c82d20de45974f81295fda9f2bd0
sha256sums = SKIP
- sha256sums = e6d965551829448ffc2ea0fdf97d7d44c3d35be0b56fc025e6cc343f29f7b9d6
pkgname = lib32-egl-wayland
diff --git a/PKGBUILD b/PKGBUILD
index 17fa3800e4ef..419dcbc095fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename=egl-wayland
pkgname="lib32-$_basename"
-pkgver=1.1.5
+pkgver=1.1.6
pkgrel=1
pkgdesc="EGLStream-based Wayland external platform (32-bit)"
arch=(x86_64)
@@ -11,11 +11,9 @@ license=(MIT)
depends=('lib32-wayland' 'eglexternalplatform' "$_basename")
makedepends=('meson' 'git')
options=(!emptydirs)
-_commit=f08e1a570eee30cbaed4c49e761830667f5ba29e # tags/1.1.5
-source=("git+$url#commit=$_commit"
- glvnd.diff)
-sha256sums=('SKIP'
- 'e6d965551829448ffc2ea0fdf97d7d44c3d35be0b56fc025e6cc343f29f7b9d6')
+_commit=1b0f2b8dd906c82d20de45974f81295fda9f2bd0 # tags/1.1.6
+source=("git+$url#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd $_basename
@@ -24,9 +22,6 @@ pkgver() {
prepare() {
cd $_basename
-
- # Fix build with headers from libglvnd
- git apply -3 ../glvnd.diff
}
build() {
diff --git a/glvnd.diff b/glvnd.diff
deleted file mode 100644
index 6182b0981a4d..000000000000
--- a/glvnd.diff
+++ /dev/null
@@ -1,108 +0,0 @@
-diff --git i/include/wayland-egldevice.h w/include/wayland-egldevice.h
-index 2b436aa..d32cce6 100644
---- i/include/wayland-egldevice.h
-+++ w/include/wayland-egldevice.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include <wayland-client.h>
- #include "wayland-external-exports.h"
- #include "wayland-eglhandle.h"
-diff --git i/include/wayland-egldisplay.h w/include/wayland-egldisplay.h
-index ac42e7b..fe11f74 100644
---- i/include/wayland-egldisplay.h
-+++ w/include/wayland-egldisplay.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include <wayland-client.h>
- #include "wayland-external-exports.h"
- #include "wayland-eglhandle.h"
-diff --git i/include/wayland-eglhandle.h w/include/wayland-eglhandle.h
-index 2697206..01bf11b 100644
---- i/include/wayland-eglhandle.h
-+++ w/include/wayland-eglhandle.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include "wayland-external-exports.h"
- #include "wayland-egl-ext.h"
- #include <pthread.h>
-diff --git i/include/wayland-eglstream-server.h w/include/wayland-eglstream-server.h
-index 27ab863..359926e 100644
---- i/include/wayland-eglstream-server.h
-+++ w/include/wayland-eglstream-server.h
-@@ -26,6 +26,7 @@
- #include <wayland-server-protocol.h>
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include "wayland-eglhandle.h"
-
- #ifdef __cplusplus
-diff --git i/include/wayland-eglstream.h w/include/wayland-eglstream.h
-index e8486be..57b5e04 100644
---- i/include/wayland-eglstream.h
-+++ w/include/wayland-eglstream.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
-
- #ifdef __cplusplus
- extern "C" {
-diff --git i/include/wayland-eglsurface.h w/include/wayland-eglsurface.h
-index 38fcd85..f292812 100644
---- i/include/wayland-eglsurface.h
-+++ w/include/wayland-eglsurface.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include <pthread.h>
- #include <wayland-client.h>
- #include "wayland-egldisplay.h"
-diff --git i/include/wayland-eglswap.h w/include/wayland-eglswap.h
-index 594f3ce..783ecbe 100644
---- i/include/wayland-eglswap.h
-+++ w/include/wayland-eglswap.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include "wayland-eglhandle.h"
- #include "wayland-eglsurface.h"
-
-diff --git i/include/wayland-eglutils.h w/include/wayland-eglutils.h
-index ae54fcb..797bee7 100644
---- i/include/wayland-eglutils.h
-+++ w/include/wayland-eglutils.h
-@@ -25,6 +25,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
- #include "wayland-external-exports.h"
- #include "wayland-eglhandle.h"
-
-diff --git i/src/wayland-eglstream-server.c w/src/wayland-eglstream-server.c
-index c37f8e6..ef4bcb5 100644
---- i/src/wayland-eglstream-server.c
-+++ w/src/wayland-eglstream-server.c
-@@ -34,6 +34,7 @@
- #include <wayland-server.h>
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
-
- #include "wayland-eglstream-server.h"
- #include "wayland-eglstream-server-protocol.h"