summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-11-23 12:52:07 -0500
committerAndrew Sun2019-11-23 12:52:07 -0500
commitd638f3a96fec4083b3a749a021fba75e02d9dee8 (patch)
tree9f56585eaa888f357e4a28452704b9e2d5582627
parent86d5ae156aa58d06e67d5e1c4906ceaac66418f3 (diff)
downloadaur-d638f3a96fec4083b3a749a021fba75e02d9dee8.tar.gz
fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--glvnd.diff108
3 files changed, 121 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87f98a37d4c8..aaa49f887ed6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-egl-wayland
pkgdesc = EGLStream-based Wayland external platform (32-bit)
pkgver = 1.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NVIDIA/egl-wayland
arch = x86_64
license = MIT
@@ -11,8 +11,10 @@ pkgbase = lib32-egl-wayland
depends = eglexternalplatform
depends = egl-wayland
options = !emptydirs
- source = git+https://github.com/NVIDIA/egl-wayland#commit=0c8e822cccff8f4ed472a7b6ac26a215ad13abc4
+ source = git+https://github.com/NVIDIA/egl-wayland#commit=47d96a84b04d21cd0a2f23b59a4936c829a65364
+ source = glvnd.diff
sha256sums = SKIP
+ sha256sums = e6d965551829448ffc2ea0fdf97d7d44c3d35be0b56fc025e6cc343f29f7b9d6
pkgname = lib32-egl-wayland
diff --git a/PKGBUILD b/PKGBUILD
index a77c85a62943..04bdb40fad12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=egl-wayland
pkgname="lib32-$_basename"
pkgver=1.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="EGLStream-based Wayland external platform (32-bit)"
arch=(x86_64)
url=https://github.com/NVIDIA/egl-wayland
@@ -11,9 +11,11 @@ license=(MIT)
depends=('lib32-wayland' 'eglexternalplatform' "$_basename")
makedepends=('meson' 'git')
options=(!emptydirs)
-_commit=0c8e822cccff8f4ed472a7b6ac26a215ad13abc4 # tags/1.1.4
-source=("git+$url#commit=$_commit")
-sha256sums=('SKIP')
+_commit=47d96a84b04d21cd0a2f23b59a4936c829a65364 # tags/1.1.4
+source=("git+$url#commit=$_commit"
+ glvnd.diff)
+sha256sums=('SKIP'
+ 'e6d965551829448ffc2ea0fdf97d7d44c3d35be0b56fc025e6cc343f29f7b9d6')
pkgver() {
cd $_basename
@@ -22,6 +24,9 @@ pkgver() {
prepare() {
cd $_basename
+
+ # Fix build with headers from libglvnd
+ git apply -3 ../glvnd.diff
}
build() {
diff --git a/glvnd.diff b/glvnd.diff
new file mode 100644
index 000000000000..6182b0981a4d
--- /dev/null
+++ b/glvnd.diff
@@ -0,0 +1,108 @@
+diff --git i/include/wayland-egldevice.h w/include/wayland-egldevice.h
+index 2b436aa..d32cce6 100644
+--- i/include/wayland-egldevice.h
++++ w/include/wayland-egldevice.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include <wayland-client.h>
+ #include "wayland-external-exports.h"
+ #include "wayland-eglhandle.h"
+diff --git i/include/wayland-egldisplay.h w/include/wayland-egldisplay.h
+index ac42e7b..fe11f74 100644
+--- i/include/wayland-egldisplay.h
++++ w/include/wayland-egldisplay.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include <wayland-client.h>
+ #include "wayland-external-exports.h"
+ #include "wayland-eglhandle.h"
+diff --git i/include/wayland-eglhandle.h w/include/wayland-eglhandle.h
+index 2697206..01bf11b 100644
+--- i/include/wayland-eglhandle.h
++++ w/include/wayland-eglhandle.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include "wayland-external-exports.h"
+ #include "wayland-egl-ext.h"
+ #include <pthread.h>
+diff --git i/include/wayland-eglstream-server.h w/include/wayland-eglstream-server.h
+index 27ab863..359926e 100644
+--- i/include/wayland-eglstream-server.h
++++ w/include/wayland-eglstream-server.h
+@@ -26,6 +26,7 @@
+ #include <wayland-server-protocol.h>
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include "wayland-eglhandle.h"
+
+ #ifdef __cplusplus
+diff --git i/include/wayland-eglstream.h w/include/wayland-eglstream.h
+index e8486be..57b5e04 100644
+--- i/include/wayland-eglstream.h
++++ w/include/wayland-eglstream.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+diff --git i/include/wayland-eglsurface.h w/include/wayland-eglsurface.h
+index 38fcd85..f292812 100644
+--- i/include/wayland-eglsurface.h
++++ w/include/wayland-eglsurface.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include <pthread.h>
+ #include <wayland-client.h>
+ #include "wayland-egldisplay.h"
+diff --git i/include/wayland-eglswap.h w/include/wayland-eglswap.h
+index 594f3ce..783ecbe 100644
+--- i/include/wayland-eglswap.h
++++ w/include/wayland-eglswap.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include "wayland-eglhandle.h"
+ #include "wayland-eglsurface.h"
+
+diff --git i/include/wayland-eglutils.h w/include/wayland-eglutils.h
+index ae54fcb..797bee7 100644
+--- i/include/wayland-eglutils.h
++++ w/include/wayland-eglutils.h
+@@ -25,6 +25,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include "wayland-external-exports.h"
+ #include "wayland-eglhandle.h"
+
+diff --git i/src/wayland-eglstream-server.c w/src/wayland-eglstream-server.c
+index c37f8e6..ef4bcb5 100644
+--- i/src/wayland-eglstream-server.c
++++ w/src/wayland-eglstream-server.c
+@@ -34,6 +34,7 @@
+ #include <wayland-server.h>
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+
+ #include "wayland-eglstream-server.h"
+ #include "wayland-eglstream-server-protocol.h"