summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Whatson2018-11-07 23:07:26 +1000
committerAndrew Whatson2018-11-07 23:07:26 +1000
commit2d9fac34cbc38a5f6ae03c760e8a24d03ee182fd (patch)
treeeaab631f38ac8d051d157a8f479f0b29288682ee
downloadaur-2d9fac34cbc38a5f6ae03c760e8a24d03ee182fd.tar.gz
Initial lib32-faudio-git pkgbuild
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
-rw-r--r--faudio.pc10
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c2b1d202b57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-faudio-git
+ pkgdesc = Accuracy-focused XAudio reimplementation for open platforms
+ pkgver = r894.27cdf05
+ pkgrel = 1
+ url = https://github.com/FNA-XNA/FAudio
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = faudio-git
+ depends = lib32-sdl2
+ depends = lib32-ffmpeg
+ source = git+https://github.com/FNA-XNA/FAudio
+ source = faudio.pc
+ sha256sums = SKIP
+ sha256sums = 371d1dfdfa335a354f41376807848ba0cc448890d6da60d0b5c9478033b7e54c
+
+pkgname = lib32-faudio-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d7c0ad3f743
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+/FAudio/
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84b9d3974416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andrew Whatson <whatson@gmail.com>
+_pkgname=faudio
+_pkgbase=${_pkgname}-git
+_gitname=FAudio
+pkgname=lib32-${_pkgbase}
+pkgver=r894.27cdf05
+pkgrel=1
+pkgdesc="Accuracy-focused XAudio reimplementation for open platforms"
+arch=('x86_64')
+url="https://github.com/FNA-XNA/FAudio"
+license=('custom')
+depends=("${_pkgbase}" 'lib32-sdl2' 'lib32-ffmpeg')
+makedepends=('git')
+source=('git+https://github.com/FNA-XNA/FAudio'
+ 'faudio.pc')
+sha256sums=('SKIP'
+ '371d1dfdfa335a354f41376807848ba0cc448890d6da60d0b5c9478033b7e54c')
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_gitname}"
+ CFLAGS="${CFLAGS} -m32" FAUDIO_RELEASE=1 FAUDIO_FFMPEG=1 make
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ _tmpdir="${pkgdir}/temp"
+ CFLAGS="${CFLAGS} -m32" FAUDIO_RELEASE=1 FAUDIO_FFMPEG=1 INSTALL_PREFIX="${_tmpdir}" make install
+ install -D -t "${pkgdir}/usr/lib32" "${_tmpdir}/lib"/*
+ install -D -m644 -t "${pkgdir}/usr/lib32/pkgconfig" ../faudio.pc
+ rm -rf "${_tmpdir}"
+}
diff --git a/faudio.pc b/faudio.pc
new file mode 100644
index 000000000000..efa964e32a37
--- /dev/null
+++ b/faudio.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+libdir=${prefix}/lib32
+includedir=${prefix}/include/FAudio
+
+Name: faudio
+Description: Accuracy-focused XAudio reimplementation for open platforms
+Version:
+
+Libs: -L${libdir} -lFAudio
+Cflags: -I${includedir}