summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2020-04-24 20:05:23 -0400
committerAlexandre Demers2020-04-24 20:05:23 -0400
commit40d216d3a489cda3140a8993e50e6e9c422bad6a (patch)
treea5227bcd7b0a57daad88c1859662e15ed94a20f2
parent3665c229093ffe811d7a722444edde8f07a506de (diff)
downloadaur-40d216d3a489cda3140a8993e50e6e9c422bad6a.tar.gz
add support for libsrt and fix x265 minimum version
Also reorganize alphabetically (almost, following ffmpeg package) depends. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddee7ac096ea..f49d3269bd0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
pkgver = 4.2.2
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = http://ffmpeg.org/
arch = x86_64
@@ -34,28 +34,30 @@ pkgbase = lib32-ffmpeg
depends = lib32-libpulse
depends = lib32-libraw1394
depends = lib32-libtheora
+ depends = lib32-libva
depends = lib32-libvdpau
+ depends = lib32-libvorbis
+ depends = lib32-libvpx
depends = lib32-libwebp
depends = lib32-libx11
+ depends = lib32-x264>=0.159
+ depends = lib32-x265>=3.3
depends = lib32-libxcb
depends = lib32-libxext
depends = lib32-libxml2
depends = lib32-libxv
+ depends = lib32-xvidcore
depends = lib32-opencore-amr
depends = lib32-openjpeg2
depends = lib32-opus
depends = lib32-sdl2
depends = lib32-speex
+ depends = lib32-srt
depends = lib32-v4l-utils
depends = lib32-xz
depends = lib32-zlib
- depends = lib32-libva
- depends = lib32-libvorbis
- depends = lib32-libvpx
- depends = lib32-x264>=159
- depends = lib32-x265
- depends = lib32-xvidcore
optdepends = lib32-ladspa: LADSPA filters
+ optdepends = lib32-nvidia-utils: Nvidia NVDEC/NVENC support
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index 57af0feb8151..0485120ce234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,14 @@
_pkgbasename=ffmpeg
pkgname=lib32-$_pkgbasename
pkgver=4.2.2
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
url="http://ffmpeg.org/"
license=('GPL3')
-depends=("$_pkgbasename"
+depends=(
+ "$_pkgbasename"
'lib32-alsa-lib'
'lib32-aom'
'lib32-bzip2'
@@ -32,6 +33,7 @@ depends=("$_pkgbasename"
'lib32-libdrm'
'lib32-freetype2'
'lib32-libiec61883'
+# 'lib32-libmfx'
'lib32-libmodplug'
'lib32-libomxil-bellagio'
'lib32-libpulse'
@@ -39,28 +41,29 @@ depends=("$_pkgbasename"
# 'lib32-libsoxr'
# 'lib32-libssh'
'lib32-libtheora'
+ 'lib32-libva'
'lib32-libvdpau'
+# 'lib32-vid.stab'
+ 'lib32-libvorbis'
+ 'lib32-libvpx'
'lib32-libwebp'
'lib32-libx11'
+ 'lib32-x264>=0.159'
+ 'lib32-x265>=3.3'
'lib32-libxcb'
'lib32-libxext'
'lib32-libxml2'
'lib32-libxv'
+ 'lib32-xvidcore'
'lib32-opencore-amr'
'lib32-openjpeg2'
'lib32-opus'
'lib32-sdl2'
'lib32-speex'
+ 'lib32-srt'
'lib32-v4l-utils'
'lib32-xz'
'lib32-zlib'
- 'lib32-libva'
-# 'lib32-vid.stab'
- 'lib32-libvorbis'
- 'lib32-libvpx'
- 'lib32-x264>=159'
- 'lib32-x265'
- 'lib32-xvidcore'
)
makedepends=(
'ffnvcodec-headers'
@@ -71,6 +74,7 @@ makedepends=(
optdepends=(
# 'intel-media-sdk: Intel QuickSync support'
'lib32-ladspa: LADSPA filters'
+ 'lib32-nvidia-utils: Nvidia NVDEC/NVENC support'
)
provides=(
'libavcodec.so'
@@ -129,6 +133,7 @@ build() {
--enable-libopus \
--enable-libpulse \
--enable-libspeex \
+ --enable-libsrt \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvorbis \
@@ -145,9 +150,10 @@ build() {
--enable-shared \
--enable-version3
-# --enable-libsoxr \ ## not available under 32bit
-# --enable-libssh \ ## not available under 32bit
-# --enable-libvidstab \ ## not available under 32bit
+# --enable-libsoxr \ ## not available under 32 bit
+# --enable-libssh \ ## not available under 32 bit
+# --enable-libvidstab \ ## not available under 32 bit
+# --enable-libmfx \ ## not available under 32 bit
make
}