summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-07-22 17:43:17 +0200
committerJohannes Dewender2015-07-22 17:44:47 +0200
commit69175ede724508de35823095bcc3894d592492b7 (patch)
treece333e2b7be833aff9f1b7f4a9d43de31546ac87
parentc5e850c984561d5e44fb4730cf51298c25291cc5 (diff)
downloadaur-69175ede724508de35823095bcc3894d592492b7.tar.gz
don't use .so dependencies exclusively
the .so dependency uses the 32 bit package if available but makepkg doesn't complain if only the 64 bit package is available. Only in the build step there is a message x264 not found. So we use lib32-libx264 for the general package and libx264.so for the versioned dependency in the binary package.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0430228ad39..7064c0a44700 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
pkgver = 2.7.2
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://ffmpeg.org/
arch = x86_64
@@ -30,8 +30,10 @@ pkgbase = lib32-ffmpeg
depends = lib32-libxv
depends = lib32-xvidcore
depends = lib32-zlib
+ depends = lib32-libvorbis
depends = libvorbis.so
depends = libvorbisenc.so
+ depends = lib32-libx264
depends = libx264.so
provides = libavcodec.so
provides = libavdevice.so
diff --git a/PKGBUILD b/PKGBUILD
index d2da9657077a..9d0613f853f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgbasename=ffmpeg
pkgname=lib32-$_pkgbasename
pkgver=2.7.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
@@ -21,7 +21,8 @@ depends=("$_pkgbasename"
'lib32-sdl' 'lib32-v4l-utils'
'lib32-libxv'
'lib32-xvidcore' 'lib32-zlib'
- 'libvorbis.so' 'libvorbisenc.so' 'libx264.so'
+ 'lib32-libvorbis' 'libvorbis.so' 'libvorbisenc.so'
+ 'lib32-libx264' 'libx264.so'
)
makedepends=('hardening-wrapper' 'yasm')
provides=(