summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2018-04-21 03:28:19 -0400
committerAlexandre Demers2018-04-21 03:30:20 -0400
commit7299939b3cf4304218a9ea368880fc7f799aee34 (patch)
tree6c5bb6050d4bd9c258eb5a84b607aace5ca104bd
parent784a96798e4ba0cd0baa7905bdddcacc5e5efded (diff)
downloadaur-7299939b3cf4304218a9ea368880fc7f799aee34.tar.gz
Update to 4.0
Fix .SRCINFO that was not properly updated in the last commit. Remove patch FS56089 since it doesn't apply anymore (and seems to be included). Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--fs56089.patch84
3 files changed, 9 insertions, 100 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d87a7df069a..20c0ec210d03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
- pkgver = 3.4.2
- pkgrel = 2
+ pkgver = 4.0
+ pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
arch = x86_64
@@ -55,13 +55,11 @@ pkgbase = lib32-ffmpeg
provides = libpostproc.so
provides = libswresample.so
provides = libswscale.so
- source = http://ffmpeg.org/releases/ffmpeg-3.4.2.tar.xz
- source = http://ffmpeg.org/releases/ffmpeg-3.4.2.tar.xz.asc
- source = fs56089.patch
+ source = http://ffmpeg.org/releases/ffmpeg-4.0.tar.xz
+ source = http://ffmpeg.org/releases/ffmpeg-4.0.tar.xz.asc
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
- sha256sums = 2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740
+ sha256sums = ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f
sha256sums = SKIP
- sha256sums = 7fdfacfe805b7f2c2c38de45c94772e49eca54fbb71918f74cd1226cfff8e9d2
pkgname = lib32-ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index cfddb540eee2..90d591738fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgbasename=ffmpeg
pkgname=lib32-$_pkgbasename
-pkgver=3.4.2
-pkgrel=2
+pkgver=4.0
+pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
@@ -60,21 +60,17 @@ provides=(
)
source=(
"http://ffmpeg.org/releases/$_pkgbasename-$pkgver.tar.xz"{,.asc}
- 'fs56089.patch'
)
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
sha256sums=(
- '2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740'
+ 'ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f'
'SKIP'
- '7fdfacfe805b7f2c2c38de45c94772e49eca54fbb71918f74cd1226cfff8e9d2'
)
prepare() {
cd ${_pkgbasename}-${pkgver}
- # https://bugs.archlinux.org/task/56089
- # Backport of http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712
- patch -Np1 -i ../fs56089.patch
+ # Patching if needed
}
build() {
@@ -123,7 +119,6 @@ build() {
--enable-version3 \
--enable-omx
-# --enable-libx265 \
# --enable-libssh \
# --enable-libsoxr \
# --enable-libx265 \
diff --git a/fs56089.patch b/fs56089.patch
deleted file mode 100644
index a0773726027f..000000000000
--- a/fs56089.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff -rupN ffmpeg-3.4.orig/libavformat/aviobuf.c ffmpeg-3.4/libavformat/aviobuf.c
---- ffmpeg-3.4.orig/libavformat/aviobuf.c 2017-11-02 14:57:16.078834563 +0100
-+++ ffmpeg-3.4/libavformat/aviobuf.c 2017-11-02 15:02:52.549816990 +0100
-@@ -531,6 +531,24 @@ void avio_write_marker(AVIOContext *s, i
- s->last_time = time;
- }
-
-+static int read_packet_wrapper(AVIOContext *s, uint8_t *buf, int size)
-+{
-+ int ret;
-+
-+ if (!s->read_packet)
-+ return AVERROR_EOF;
-+ ret = s->read_packet(s->opaque, buf, size);
-+#if FF_API_OLD_AVIO_EOF_0
-+ if (!ret && !s->max_packet_size) {
-+ av_log(NULL, AV_LOG_WARNING, "Invalid return value 0 for stream protocol\n");
-+ ret = AVERROR_EOF;
-+ }
-+#else
-+ av_assert2(ret || s->max_packet_size);
-+#endif
-+ return ret;
-+}
-+
- /* Input stream */
-
- static void fill_buffer(AVIOContext *s)
-@@ -569,10 +587,7 @@ static void fill_buffer(AVIOContext *s)
- len = s->orig_buffer_size;
- }
-
-- if (s->read_packet)
-- len = s->read_packet(s->opaque, dst, len);
-- else
-- len = 0;
-+ len = read_packet_wrapper(s, dst, len);
- if (len <= 0) {
- /* do not modify buffer if EOF reached so that a seek back can
- be done without rereading data */
-@@ -644,8 +659,7 @@ int avio_read(AVIOContext *s, unsigned c
- if (len == 0 || s->write_flag) {
- if((s->direct || size > s->buffer_size) && !s->update_checksum) {
- // bypass the buffer and read data directly into buf
-- if(s->read_packet)
-- len = s->read_packet(s->opaque, buf, size);
-+ len = read_packet_wrapper(s, buf, size);
-
- if (len <= 0) {
- /* do not modify buffer if EOF reached so that a seek back can
-@@ -711,7 +725,7 @@ int avio_read_partial(AVIOContext *s, un
- return -1;
-
- if (s->read_packet && s->write_flag) {
-- len = s->read_packet(s->opaque, buf, size);
-+ len = read_packet_wrapper(s, buf, size);
- if (len > 0)
- s->pos += len;
- return len;
-diff -rupN ffmpeg-3.4.orig/libavformat/avio.h ffmpeg-3.4/libavformat/avio.h
---- ffmpeg-3.4.orig/libavformat/avio.h 2017-11-02 14:57:16.078834563 +0100
-+++ ffmpeg-3.4/libavformat/avio.h 2017-11-02 14:59:15.602300896 +0100
-@@ -452,6 +452,8 @@ void avio_free_directory_entry(AVIODirEn
- * @param write_flag Set to 1 if the buffer should be writable, 0 otherwise.
- * @param opaque An opaque pointer to user-specific data.
- * @param read_packet A function for refilling the buffer, may be NULL.
-+ * For stream protocols, must never return 0 but rather
-+ * a proper AVERROR code.
- * @param write_packet A function for writing the buffer contents, may be NULL.
- * The function may not change the input buffers content.
- * @param seek A function for seeking to specified byte position, may be NULL.
-diff -rupN ffmpeg-3.4.orig/libavformat/version.h ffmpeg-3.4/libavformat/version.h
---- ffmpeg-3.4.orig/libavformat/version.h 2017-11-02 14:57:16.082167807 +0100
-+++ ffmpeg-3.4/libavformat/version.h 2017-11-02 15:04:01.704627612 +0100
-@@ -97,6 +97,9 @@
- #ifndef FF_API_OLD_ROTATE_API
- #define FF_API_OLD_ROTATE_API (LIBAVFORMAT_VERSION_MAJOR < 58)
- #endif
-+#ifndef FF_API_OLD_AVIO_EOF_0
-+#define FF_API_OLD_AVIO_EOF_0 (LIBAVFORMAT_VERSION_MAJOR < 58)
-+#endif
-
-
- #ifndef FF_API_R_FRAME_RATE