summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2019-08-15 13:06:50 -0400
committerAlexandre Demers2019-08-15 13:06:50 -0400
commit79eeee5a2c8b0d99cb81336ec04fd44b379f247d (patch)
tree0e495663f5827f2d5b8c7fdbf01d5ce1d5a72e3e
parent9d20589a01a12f5e64b3e625a8cc49cb2416af96 (diff)
downloadaur-79eeee5a2c8b0d99cb81336ec04fd44b379f247d.tar.gz
Add dav1d support
Change order of some dependencies to follow the official package. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36526398dac3..d6a6bbc2a5af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
pkgver = 4.2
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://ffmpeg.org/
arch = x86_64
@@ -22,8 +22,12 @@ pkgbase = lib32-ffmpeg
depends = lib32-gsm
depends = lib32-jack
depends = lib32-lame
+ depends = lib32-libass
depends = lib32-libavc1394
+ depends = lib32-libbluray
+ depends = lib32-dav1d
depends = lib32-libdrm
+ depends = lib32-freetype2
depends = lib32-libiec61883
depends = lib32-libmodplug
depends = lib32-libomxil-bellagio
@@ -45,9 +49,6 @@ pkgbase = lib32-ffmpeg
depends = lib32-v4l-utils
depends = lib32-xz
depends = lib32-zlib
- depends = lib32-libass
- depends = lib32-libbluray
- depends = lib32-freetype2
depends = lib32-libva
depends = lib32-libvorbis
depends = lib32-libvpx
diff --git a/PKGBUILD b/PKGBUILD
index 912bde610bbd..e37bca4f1941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbasename=ffmpeg
pkgname=lib32-$_pkgbasename
pkgver=4.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
@@ -25,8 +25,12 @@ depends=("$_pkgbasename"
'lib32-gsm'
'lib32-jack'
'lib32-lame'
+ 'lib32-libass'
'lib32-libavc1394'
+ 'lib32-libbluray'
+ 'lib32-dav1d'
'lib32-libdrm'
+ 'lib32-freetype2'
'lib32-libiec61883'
'lib32-libmodplug'
'lib32-libomxil-bellagio'
@@ -50,9 +54,6 @@ depends=("$_pkgbasename"
'lib32-v4l-utils'
'lib32-xz'
'lib32-zlib'
- 'lib32-libass'
- 'lib32-libbluray'
- 'lib32-freetype2'
'lib32-libva'
# 'lib32-vid.stab'
'lib32-libvorbis'
@@ -61,12 +62,23 @@ depends=("$_pkgbasename"
'lib32-x265'
'lib32-xvidcore'
)
-makedepends=('ffnvcodec-headers' 'git' 'lib32-ladspa' 'yasm')
+makedepends=(
+ 'ffnvcodec-headers'
+ 'git'
+ 'lib32-ladspa'
+ 'yasm'
+ )
optdepends=('lib32-ladspa: LADSPA filters')
provides=(
- 'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
- 'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
-)
+ 'libavcodec.so'
+ 'libavdevice.so'
+ 'libavfilter.so'
+ 'libavformat.so'
+ 'libavutil.so'
+ 'libpostproc.so'
+ 'libswresample.so'
+ 'libswscale.so'
+ )
source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}")
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
sha256sums=('SKIP')
@@ -98,6 +110,7 @@ build() {
--enable-libaom \
--enable-libass \
--enable-libbluray \
+ --enable-libdav1d \
--enable-libdrm \
--enable-libfreetype \
--enable-libfribidi \
@@ -131,7 +144,6 @@ build() {
# --enable-libsoxr \ ## not available under 32bit
# --enable-libssh \ ## not available under 32bit
# --enable-libvidstab \ ## not available under 32bit
-# --enable-libdav1d \ ## not available under 32bit
make
}