summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-08-11 01:51:33 -0400
committerVincent Grande2019-08-11 01:51:33 -0400
commit8b61f5da4d588aecdb3b4cd369eb1ff624215857 (patch)
treec81b6e68d40b38d3492040e423f17dea3dc28d5d
downloadaur-8b61f5da4d588aecdb3b4cd369eb1ff624215857.tar.gz
did a thing
-rw-r--r--.SRCINFO27
-rwxr-xr-xPKGBUILD76
-rwxr-xr-xfontconfig-32.hook11
-rwxr-xr-xlib32-fontconfig.install10
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c31766bb5f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lib32-fontconfig-git
+ pkgdesc = A library for configuring and customizing font access (32-bit)
+ pkgver = 2.13.91+18+g01e4f08
+ pkgrel = 1
+ epoch = 2
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
+ install = lib32-fontconfig.install
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = autoconf-archive
+ makedepends = gperf
+ makedepends = python-lxml
+ makedepends = python-six
+ makedepends = lib32-json-c
+ depends = lib32-expat
+ depends = lib32-freetype2
+ depends = fontconfig
+ provides = lib32-fontconfig
+ conflicts = lib32-fontconfig
+ source = git+https://anongit.freedesktop.org/git/fontconfig
+ source = fontconfig-32.hook
+ sha256sums = SKIP
+ sha256sums = d97c0c5b88023da5a2acf64cf560265390a9365305c43b8e86b4f89348e727b3
+
+pkgname = lib32-fontconfig-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..b9381e8a8873
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_pkgbasename=fontconfig
+pkgname=lib32-$_pkgbasename-git
+pkgver=2.13.91+18+g01e4f08
+pkgrel=1
+epoch=2
+pkgdesc="A library for configuring and customizing font access (32-bit)"
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+license=(custom)
+provides=(lib32-fontconfig)
+conflicts=(lib32-fontconfig)
+depends=(lib32-expat lib32-freetype2 $_pkgbasename)
+makedepends=(git autoconf-archive gperf python-lxml python-six lib32-json-c)
+install=lib32-fontconfig.install
+#_commit=5f5ec5676c61b9773026a9335c9b0dfa73a73353 # master
+source=("git+https://anongit.freedesktop.org/git/fontconfig"
+ fontconfig-32.hook)
+sha256sums=('SKIP'
+ 'd97c0c5b88023da5a2acf64cf560265390a9365305c43b8e86b4f89348e727b3')
+
+# a nice page to test font matching:
+# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+# http://getemoji.com/
+
+pkgver() {
+ cd $_pkgbasename
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgbasename
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgbasename
+
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts
+ make
+}
+
+#check() {
+# cd $_pkgbasename
+# make -k check
+#}
+
+package() {
+ cd $_pkgbasename
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/{etc,usr/{include,share}}
+ find "$pkgdir/usr/bin" -not -type d -not -name fc-cache -delete
+ mv "$pkgdir"/usr/bin/fc-cache{,-32}
+
+ install -Dm644 ../fontconfig-32.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig-32.hook"
+
+ # Install license
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/fontconfig-32.hook b/fontconfig-32.hook
new file mode 100755
index 000000000000..e19434776940
--- /dev/null
+++ b/fontconfig-32.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/fonts/*
+
+[Action]
+Description = Updating 32-bit fontconfig cache...
+When = PostTransaction
+Exec = /usr/bin/fc-cache-32 -s
diff --git a/lib32-fontconfig.install b/lib32-fontconfig.install
new file mode 100755
index 000000000000..a02b1e7a71e4
--- /dev/null
+++ b/lib32-fontconfig.install
@@ -0,0 +1,10 @@
+post_install() {
+ post_upgrade $1
+}
+
+post_upgrade() {
+ echo -n "Rebuilding 32-bit fontconfig cache..."
+ # a full forced directory scan is required here
+ /usr/bin/fc-cache-32 -rs
+ echo " done."
+}