summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsudoBash4182019-06-16 00:15:04 -0600
committersudoBash4182019-06-16 00:15:04 -0600
commitda83360943f30e157613ba95ef9429ef3546e0c1 (patch)
tree32ccf221ccf9bc37457c2a3c26c5d917c2f1f71b
parent96fe1d69e4934610bf20285975e70cc31e803805 (diff)
downloadaur-da83360943f30e157613ba95ef9429ef3546e0c1.tar.gz
Update to 3.6.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee8d4bf8d6ac..bb74797528b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-fuse3
pkgdesc = A library that makes it possible to implement a filesystem in a userspace program (32 bit)
- pkgver = 3.5.0
+ pkgver = 3.6.1
pkgrel = 1
url = https://github.com/libfuse/libfuse
arch = x86_64
@@ -11,10 +11,10 @@ pkgbase = lib32-fuse3
depends = lib32-glibc
depends = fuse3
options = !libtool
- source = https://github.com/libfuse/libfuse/releases/download/fuse-3.5.0/fuse-3.5.0.tar.xz
- source = https://github.com/libfuse/libfuse/releases/download/fuse-3.5.0/fuse-3.5.0.tar.xz.asc
+ source = https://github.com/libfuse/libfuse/releases/download/fuse-3.6.1/fuse-3.6.1.tar.xz
+ source = https://github.com/libfuse/libfuse/releases/download/fuse-3.6.1/fuse-3.6.1.tar.xz.asc
validpgpkeys = ED31791B2C5C1613AF388B8AD113FCAC3C4E599F
- sha256sums = 75bfee6b730145483d18238b50daccde4c1b8133fa1703367fbf8088d0666bf0
+ sha256sums = 6dc3b702f2d13187ff4adb8bcbdcb913ca0510ce0020e4d87bdeb4d794173704
sha256sums = SKIP
pkgname = lib32-fuse3
diff --git a/PKGBUILD b/PKGBUILD
index 75c5d3e00af6..35eadb07a0b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=fuse
pkgname=lib32-fuse3
-pkgver=3.5.0
+pkgver=3.6.1
pkgrel=1
pkgdesc="A library that makes it possible to implement a filesystem in a userspace program (32 bit)"
arch=('x86_64')
@@ -13,14 +13,15 @@ depends=('lib32-glibc' 'fuse3')
makedepends=('gcc-multilib' 'meson' 'pkg-config')
source=(${url}/releases/download/${_pkgbase}-${pkgver}/${_pkgbase}-${pkgver}.tar.xz{,.asc})
options=(!libtool)
-sha256sums=('75bfee6b730145483d18238b50daccde4c1b8133fa1703367fbf8088d0666bf0'
+sha256sums=('6dc3b702f2d13187ff4adb8bcbdcb913ca0510ce0020e4d87bdeb4d794173704'
'SKIP')
validpgpkeys=(ED31791B2C5C1613AF388B8AD113FCAC3C4E599F)
build() {
# based off fuse3's build function
- export CC="gcc -m32"
+ export CFLAGS="-m32"
+ export CXXFLAGS="-m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd "${_pkgbase}-${pkgver}"