summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorysblokje2020-09-11 21:37:29 +0200
committerysblokje2020-09-11 21:37:29 +0200
commit0ce35227f12bf85c072b8bf888b04379f67a3800 (patch)
tree81d3f3bc00abae8c95418926792a0d8b0b3940e8
parent05cab824100cc715cf72565fc73f1d52868b8fea (diff)
downloadaur-0ce35227f12bf85c072b8bf888b04379f67a3800.tar.gz
remove all the things.... except libs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9102fbf36974..f17c69c01071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gamemode
pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS
pkgver = 1.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FeralInteractive/gamemode.git
arch = x86_64
license = BSD 3-Clause License (Revised)
diff --git a/PKGBUILD b/PKGBUILD
index 86abc0e3b434..f9710c0a8deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('lib32-gamemode')
_pkgname=('gamemode')
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS"
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
@@ -18,13 +18,16 @@ build() {
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
meson ${_pkgname}-$pkgver build --prefix /usr \
- -Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false -Dwith-util=false --libdir lib32
+ -Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false -Dwith-util=false -Dwith-examples=false --libdir lib32
ninja -C build
}
package() {
DESTDIR=$pkgdir ninja -C build install
rm -rf $pkgdir/usr/include
+ rm -rf $pkgdir/usr/bin
+ rm -rf $pkgdir/usr/share
+ rm -rf $pkgdir/usr/lib/systemd
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${_pkgname}-${pkgver}/LICENSE.txt
}