summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2018-05-14 11:44:57 +0200
committerMinze Zwerver2018-05-14 11:44:57 +0200
commit10e318f1e4e006782d4d25290222c623aa0fe610 (patch)
treef03591ccad5ff9b08396b1246734ec8266a20196
parent7e772859edd489ed08c690cf5aca49a1081a46bf (diff)
downloadaur-10e318f1e4e006782d4d25290222c623aa0fe610.tar.gz
bump to 1.1
Also switched to git checkout instead of release tar.gz
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6573e64e34a..fc5a774feb36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gamemode
pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
- pkgver = 1.0
- pkgrel = 2
+ pkgver = 1.1
+ pkgrel = 1
url = https://github.com/FeralInteractive/gamemode.git
arch = x86_64
license = BSD 3-Clause License (Revised)
@@ -13,8 +13,8 @@ pkgbase = lib32-gamemode
depends = gamemode
depends = lib32-glibc
provides = lib32-gamemode
- source = https://github.com/FeralInteractive/gamemode/archive/1.0.tar.gz
- sha256sums = bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d
+ source = lib32-gamemode-1.1::git+https://github.com/FeralInteractive/gamemode.git#tag=1.1
+ sha256sums = SKIP
pkgname = lib32-gamemode
diff --git a/PKGBUILD b/PKGBUILD
index dbd5450995a5..919bbc17dc07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
pkgname=('lib32-gamemode')
_pkgname=('gamemode')
-pkgver=1.0
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
@@ -10,15 +10,18 @@ license=('BSD 3-Clause License (Revised)')
depends=('gamemode' 'lib32-glibc')
makedepends=('meson' 'ninja' 'pkg-config' 'git' 'lib32-systemd')
provides=('lib32-gamemode')
-source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
-sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
+source=("$pkgname-$pkgver::git+https://github.com/FeralInteractive/gamemode.git#tag=$pkgver")
+#source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
+#sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
+sha256sums=('SKIP')
+
build() {
export CFLAGS=-m32
export CXXFLAGS=-m32
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- arch-meson gamemode-$pkgver build \
+ arch-meson ${pkgname}-$pkgver build \
-Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false --libdir lib32
ninja -C build
}
@@ -26,6 +29,6 @@ build() {
package() {
DESTDIR=$pkgdir ninja -C build install
rm -rf $pkgdir/usr/include
- install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${_pkgname}-${pkgver}/LICENSE.txt
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${pkgname}-${pkgver}/LICENSE.txt
}