summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-09-14 17:07:26 -0600
committerMark Wagie2020-09-14 17:07:26 -0600
commit263a1b3197efe1e848fcd8212fc65ea9028cd233 (patch)
tree97901c536ea7714d79d868705ba2a1e0b35384b2
parentf3eb49bdb4acccef983d1e590c82a2d2b8439d00 (diff)
downloadaur-263a1b3197efe1e848fcd8212fc65ea9028cd233.tar.gz
update build for Meson package guidelines, add check()
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b34a4fb3899..fef537a78da2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = lib32-gamemode
url = https://github.com/FeralInteractive/gamemode
arch = x86_64
license = BSD 3-Clause License (Revised)
+ checkdepends = appstream
makedepends = meson
makedepends = lib32-systemd
depends = gamemode
diff --git a/PKGBUILD b/PKGBUILD
index 9474b0d3fe5f..4de8416fb0bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url="https://github.com/FeralInteractive/gamemode"
license=('BSD 3-Clause License (Revised)')
depends=('gamemode' 'lib32-glibc' 'lib32-dbus')
makedepends=('meson' 'lib32-systemd')
+checkdepends=('appstream')
source=("$url/releases/download/$pkgver/$_pkgname-$pkgver.tar.xz")
sha256sums=('4fec5a0900e8f559b37cf1711ca7dcea7e1cebfe1237ce314001f65c1e346a5d')
@@ -25,11 +26,15 @@ build() {
-Dwith-systemd=false \
-Dwith-util=false \
--libdir lib32
- ninja -C build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
}
package() {
- DESTDIR=$pkgdir ninja -C build install
+ DESTDIR=$pkgdir meson install -C build
rm -rf $pkgdir/usr/include
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${_pkgname}-${pkgver}/LICENSE.txt
}