summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2018-04-11 12:56:37 +0200
committerMinze Zwerver2018-04-11 12:56:37 +0200
commit9805be586ae3c8ce9b594de26919782c80f3b7dd (patch)
tree5edcacc4d03532639f1e19750ebfdf00f0c1234a
downloadaur-9805be586ae3c8ce9b594de26919782c80f3b7dd.tar.gz
1st commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af37e14780c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-gamemode
+ pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/FeralInteractive/gamemode.git
+ arch = x86_64
+ license = BSD 3-Clause License (Revised)
+ makedepends = meson
+ makedepends = ninja
+ makedepends = pkg-config
+ makedepends = git
+ depends = gamemode
+ depends = lib32-glibc
+ provides = lib32-gamemode
+ source = https://github.com/FeralInteractive/gamemode/archive/1.0.tar.gz
+ sha256sums = bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d
+
+pkgname = lib32-gamemode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b352dbe680ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ysblokje <ysblokje at gmail dot com>
+pkgname=('lib32-gamemode')
+_pkgname=('gamemode')
+pkgver=1.0
+pkgrel=1
+pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
+arch=('x86_64')
+url="https://github.com/FeralInteractive/gamemode.git"
+license=('BSD 3-Clause License (Revised)')
+depends=('gamemode' 'lib32-glibc')
+makedepends=('meson' 'ninja' 'pkg-config' 'git')
+provides=('lib32-gamemode')
+source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
+sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
+
+build() {
+ export CFLAGS=-m32
+ export CXXFLAGS=-m32
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ arch-meson gamemode-$pkgver build \
+ -Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false --libdir lib32
+ ninja -C build
+}
+
+package() {
+ DESTDIR=$pkgdir ninja -C build install
+ rm -rf $pkgdir/usr/include
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${_pkgname}-${pkgver}/LICENSE.txt
+}
+