summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2018-05-18 08:05:03 +0200
committerMinze Zwerver2018-05-18 08:05:03 +0200
commitd34f777bd902f635278e90ded78e2f7c96601538 (patch)
treeb8bf40853b82cf9d74beff40e79b5e949783345a
parent10e318f1e4e006782d4d25290222c623aa0fe610 (diff)
downloadaur-d34f777bd902f635278e90ded78e2f7c96601538.tar.gz
moved back to downloading archives
the release tarball got fixed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc5a774feb36..4921a44463d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gamemode
pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
pkgver = 1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FeralInteractive/gamemode.git
arch = x86_64
license = BSD 3-Clause License (Revised)
@@ -13,8 +13,8 @@ pkgbase = lib32-gamemode
depends = gamemode
depends = lib32-glibc
provides = lib32-gamemode
- source = lib32-gamemode-1.1::git+https://github.com/FeralInteractive/gamemode.git#tag=1.1
- sha256sums = SKIP
+ source = https://github.com/FeralInteractive/gamemode/releases/download/1.1/gamemode-1.1.tar.xz
+ sha256sums = 466a8a0798e1abf09aa3b3b08f139f19c7d950361a99ae0cfad031828d9fd211
pkgname = lib32-gamemode
diff --git a/PKGBUILD b/PKGBUILD
index 919bbc17dc07..5581cb1b6728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('lib32-gamemode')
_pkgname=('gamemode')
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
@@ -10,18 +10,15 @@ license=('BSD 3-Clause License (Revised)')
depends=('gamemode' 'lib32-glibc')
makedepends=('meson' 'ninja' 'pkg-config' 'git' 'lib32-systemd')
provides=('lib32-gamemode')
-source=("$pkgname-$pkgver::git+https://github.com/FeralInteractive/gamemode.git#tag=$pkgver")
-#source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
-#sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
-sha256sums=('SKIP')
-
+source=("https://github.com/FeralInteractive/gamemode/releases/download/$pkgver/$_pkgname-$pkgver.tar.xz")
+sha256sums=('466a8a0798e1abf09aa3b3b08f139f19c7d950361a99ae0cfad031828d9fd211')
build() {
export CFLAGS=-m32
export CXXFLAGS=-m32
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- arch-meson ${pkgname}-$pkgver build \
+ arch-meson ${_pkgname}-$pkgver build \
-Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false --libdir lib32
ninja -C build
}
@@ -29,6 +26,6 @@ build() {
package() {
DESTDIR=$pkgdir ninja -C build install
rm -rf $pkgdir/usr/include
- install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${pkgname}-${pkgver}/LICENSE.txt
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${_pkgname}-${pkgver}/LICENSE.txt
}