summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2019-03-15 23:15:07 +0100
committerMinze Zwerver2019-03-15 23:15:07 +0100
commitfa6ed68777fc5bcb61f165ca9c2431d3e30a8d2b (patch)
tree2bb2c485b1e4234959dec39f0ebf8bae51ec0b37
parentb9e9b68d70375865525659a636e883a110d62b07 (diff)
downloadaur-fa6ed68777fc5bcb61f165ca9c2431d3e30a8d2b.tar.gz
version bump to 1.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e610ddcf0757..04ddf847c0c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gamemode
pkgdesc = A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
- pkgver = 1.2
- pkgrel = 0
+ pkgver = 1.3
+ pkgrel = 1
url = https://github.com/FeralInteractive/gamemode.git
arch = x86_64
license = BSD 3-Clause License (Revised)
@@ -13,8 +13,8 @@ pkgbase = lib32-gamemode
depends = gamemode
depends = lib32-glibc
provides = lib32-gamemode
- source = https://github.com/FeralInteractive/gamemode/releases/download/1.2/gamemode-1.2.tar.xz
- sha256sums = a7b8d63ffdcbea0dc8b557fda42a9471fa9ab0961a5450d2a15cccca0aaf6a95
+ source = https://github.com/FeralInteractive/gamemode/releases/download/1.3/gamemode-1.3.tar.xz
+ sha256sums = a2918d46b29b989af1292899e4c7f6fe3a042c6d33b360b49614588e444bd715
pkgname = lib32-gamemode
diff --git a/PKGBUILD b/PKGBUILD
index 655fca543b2b..de40fc33c43a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
pkgname=('lib32-gamemode')
_pkgname=('gamemode')
-pkgver=1.2
-pkgrel=0
+pkgver=1.3
+pkgrel=1
pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
@@ -11,14 +11,14 @@ depends=('gamemode' 'lib32-glibc')
makedepends=('meson' 'ninja' 'pkg-config' 'git' 'lib32-systemd')
provides=('lib32-gamemode')
source=("https://github.com/FeralInteractive/gamemode/releases/download/$pkgver/$_pkgname-$pkgver.tar.xz")
-sha256sums=('a7b8d63ffdcbea0dc8b557fda42a9471fa9ab0961a5450d2a15cccca0aaf6a95')
+sha256sums=('a2918d46b29b989af1292899e4c7f6fe3a042c6d33b360b49614588e444bd715')
build() {
export CFLAGS=-m32
export CXXFLAGS=-m32
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- arch-meson ${_pkgname}-$pkgver build \
+ meson ${_pkgname}-$pkgver build --prefix /usr \
-Dwith-daemon=false -Dwith-examples=false -Dwith-systemd=false --libdir lib32
ninja -C build
}