summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquín Ignacio Aramendía2023-03-01 16:46:39 -0300
committerJoaquín Ignacio Aramendía2023-03-01 16:46:39 -0300
commitb7278775c184d944e86a8e6cd94641fd3b3c9ed3 (patch)
tree73d085e4114d7a5b62d7a9c99971871a6383b386
downloadaur-b7278775c184d944e86a8e6cd94641fd3b3c9ed3.tar.gz
Initial version
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD104
2 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2d450436076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = lib32-gamescope-plus
+ pkgdesc = SteamOS session compositing window manager with added patches (32-bit)
+ pkgver = 3.11.52.beta2.2.g5756c73
+ pkgrel = 1
+ url = https://github.com/Samsagax/gamescope
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = patch
+ makedepends = cmake
+ makedepends = vulkan-headers
+ depends = lib32-wayland
+ depends = lib32-libx11
+ depends = lib32-libxcb
+ depends = lib32-vulkan-icd-loader
+ provides = gamescope
+ conflicts = gamescope
+ source = git+https://github.com/Samsagax/gamescope.git#commit=5756c73470f4427be02e88b78b4776a4ce20abb9
+ source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://gitlab.freedesktop.org/emersion/libliftoff.git
+ source = git+https://gitlab.freedesktop.org/emersion/libdisplay-info.git
+ source = git+https://github.com/ValveSoftware/openvr.git
+ source = git+https://github.com/Joshua-Ashton/vkroots.git
+ source = git+https://github.com/nothings/stb.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = lib32-gamescope-plus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79913ca1f27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,104 @@
+# Maintainer: Joaquín Aramendía <samsagax at gmail dot com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Samuel "scrufulufugus" Monson <smonson@irbash.net>
+# Contributor: PedroHLC <root@pedrohlc.com>
+
+_pkgname=gamescope
+pkgname=lib32-gamescope-plus
+pkgver=3.11.52.beta2.2.g5756c73
+pkgrel=1
+pkgdesc='SteamOS session compositing window manager with added patches (32-bit)'
+arch=(x86_64)
+url=https://github.com/Samsagax/gamescope
+license=(BSD)
+conflicts=(lib32-gamescope)
+provides=(lib32-gamescope)
+depends=(
+ lib32-wayland
+ lib32-libx11
+ lib32-libxcb
+ lib32-vulkan-icd-loader
+)
+makedepends=(
+ git
+ meson
+ ninja
+ patch
+ cmake
+ vulkan-headers
+)
+_tag=5756c73470f4427be02e88b78b4776a4ce20abb9
+source=("git+https://github.com/Samsagax/gamescope.git#commit=${_tag}"
+ "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://gitlab.freedesktop.org/emersion/libliftoff.git"
+ "git+https://gitlab.freedesktop.org/emersion/libdisplay-info.git"
+ "git+https://github.com/Joshua-Ashton/vkroots.git"
+ "git+https://github.com/nothings/stb.git")
+
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ git apply "../$src"
+ done
+
+ git submodule init
+ git config submodule.subprojects/wlroots.url "$srcdir/wlroots"
+ git config submodule.subprojects/libliftoff.url "$srcdir/libliftoff"
+ git config submodule.subprojects/libdisplay-info.url "$srcdir/libdisplay-info"
+ git config submodule.subprojects/vkroots.url "$srcdir/vkroots"
+ git -c protocol.file.allow=always submodule update
+
+ # make stb.wrap use our local clone
+ sed -i "s|https://github.com/nothings/stb.git|$srcdir/stb|" "subprojects/stb.wrap"
+
+ meson subprojects download
+}
+
+pkgver() {
+ cd gamescope
+ git describe --tags | sed 's/\-/\./g'
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
+ export LDFLAGS="$LDFLAGS -lrt"
+ arch-meson gamescope build \
+ --libdir=/usr/lib32 \
+ --buildtype release \
+ --prefix /usr \
+ -Denable_gamescope=false \
+ -Denable_openvr_support=false \
+ -Dforce_fallback_for=stb,libliftoff,wlroots \
+ -Dpipewire=disabled \
+ -Dwlroots:backends=drm,libinput,x11 \
+ -Dwlroots:renderers=gles2,vulkan
+ ninja -C build
+}
+
+package() {
+ meson install -C build --skip-subprojects --destdir="${pkgdir}"
+ install -Dm 644 gamescope/LICENSE -t "${pkgdir}"/usr/share/licenses/lib32-gamescope-plus/
+
+ rm -rf "$pkgdir"/usr/include
+ rm -rf "$pkgdir"/usr/lib/libwlroots*
+ rm -rf "$pkgdir"/usr/lib32/libwlroots*
+ rm -rf "$pkgdir"/usr/lib/pkgconfig
+ rm -rf "$pkgdir"/usr/lib32/pkgconfig
+}
+
+# vim: ts=2 sw=2 et: