summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2023-05-11 11:35:51 +0330
committerBehnam Momeni2023-05-11 11:35:51 +0330
commit2d733d105151c05ae4ab2522e54f59f2a9ef68ca (patch)
tree42cf50b546ad4acc460c3d0203ebd2d5b6e4950d
parenta7e18c7091c11661920b1995a5a283f40e49f7f6 (diff)
downloadaur-2d733d105151c05ae4ab2522e54f59f2a9ef68ca.tar.gz
Upgrade to upstream version 0.4.44
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--libraw-0.21.patch12
3 files changed, 6 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4656d95f00d..be9854608bf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 27 15:09:05 UTC 2022
+# Thu May 11 08:04:13 UTC 2023
pkgbase = lib32-gegl
pkgdesc = Graph based image processing framework (32-bit)
- pkgver = 0.4.40
+ pkgver = 0.4.44
pkgrel = 1
url = https://www.gegl.org/
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = lib32-gegl
makedepends = lib32-gobject-introspection
makedepends = lib32-sdl2
makedepends = python-gobject
- depends = gegl>=0.4.40
+ depends = gegl>=0.4.44
depends = lib32-babl
depends = lib32-libspiro
depends = lib32-json-glib
@@ -36,11 +36,9 @@ pkgbase = lib32-gegl
depends = lib32-suitesparse
depends = lib32-ffmpeg
depends = ffmpeg
- source = git+https://gitlab.gnome.org/GNOME/gegl.git#commit=b3222c10c5ce8760bcd2a603dad2b3deb50fde6c
- source = libraw-0.21.patch
+ source = git+https://gitlab.gnome.org/GNOME/gegl.git#commit=f58385300356e739491b4cf803e0f9591e34dd40
source = x86-linux-gnu
sha512sums = SKIP
- sha512sums = 25a4b3792dbbe87782d76657e57638c23c8e6cd3b1badadb1d614222099bda0d66b0c79b066c9266ed4abf6427f15274b09d0a9e5205d8edb531c1ac36dfcd0d
sha512sums = 97c193bdf744a8853b4463dd9f995faea0e8b269b1b7ef3b9ffcf10c173aa44a0e6edcda5cb69be71af8a4a649332cb841ac5849ea8256f0cfeb5a3cedea251c
pkgname = lib32-gegl
diff --git a/PKGBUILD b/PKGBUILD
index 2a626e9251a3..01e251a15019 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=lib32-gegl
_pkgbase=gegl
-pkgver=0.4.40
-_commit=b3222c10c5ce8760bcd2a603dad2b3deb50fde6c # tags/GEGL_0_4_40
+pkgver=0.4.44
+_commit=f58385300356e739491b4cf803e0f9591e34dd40 # tags/GEGL_0_4_44
pkgrel=1
pkgdesc="Graph based image processing framework (32-bit)"
arch=('x86_64')
@@ -23,10 +23,8 @@ makedepends=('intltool' 'ruby' 'mesa' 'glu' 'exiv2' 'meson' 'vala'
'xorgproto' 'shared-mime-info' 'lib32-gobject-introspection'
'lib32-sdl2' 'python-gobject')
source=("git+https://gitlab.gnome.org/GNOME/$_pkgbase.git#commit=$_commit"
- "libraw-0.21.patch"
"x86-linux-gnu")
sha512sums=('SKIP'
- '25a4b3792dbbe87782d76657e57638c23c8e6cd3b1badadb1d614222099bda0d66b0c79b066c9266ed4abf6427f15274b09d0a9e5205d8edb531c1ac36dfcd0d'
'97c193bdf744a8853b4463dd9f995faea0e8b269b1b7ef3b9ffcf10c173aa44a0e6edcda5cb69be71af8a4a649332cb841ac5849ea8256f0cfeb5a3cedea251c')
prepare() {
@@ -36,8 +34,6 @@ prepare() {
for pkg in xproto.pc kbproto.pc xextproto.pc renderproto.pc shared-mime-info.pc; do
cp "/usr/share/pkgconfig/$pkg" "$srcdir/"
done
- cd "$_pkgbase"
- patch -p1 < "$srcdir"/libraw-0.21.patch
}
build() {
diff --git a/libraw-0.21.patch b/libraw-0.21.patch
deleted file mode 100644
index b05ba5598aa9..000000000000
--- a/libraw-0.21.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN gegl.orig/operations/external/raw-load.c gegl/operations/external/raw-load.c
---- gegl.orig/operations/external/raw-load.c 2022-12-27 18:33:32.189320103 +0330
-+++ gegl/operations/external/raw-load.c 2022-12-27 18:34:23.096128846 +0330
-@@ -114,7 +114,7 @@
- g_warning ("raw-load: Error Initializing raw library");
- else
- {
-- p->LibRaw->params.shot_select = o->image_num;
-+ p->LibRaw->rawparams.shot_select = o->image_num;
-
- p->LibRaw->params.aber[0] = 1.0;
- p->LibRaw->params.aber[2] = 1.0;