summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2020-01-31 18:02:02 +0330
committerBehnam Momeni2020-01-31 18:02:02 +0330
commitf6d85f0914c2d9ccaa11783195efc208e8a14a29 (patch)
tree42bc07242e477b4dcb6b0756e5182a7bf2d50a0a
downloadaur-f6d85f0914c2d9ccaa11783195efc208e8a14a29.tar.gz
Initial commit; version 0.4.20
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rwxr-xr-xpkgconf322
-rw-r--r--x86-linux-gnu18
5 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a60c4bc87090
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+# Generated by mksrcinfo v8
+# Fri Jan 31 14:31:36 UTC 2020
+pkgbase = lib32-gegl
+ pkgdesc = Graph based image processing framework (32-bit)
+ pkgver = 0.4.20
+ pkgrel = 1
+ url = https://www.gegl.org/
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = intltool
+ makedepends = ruby
+ makedepends = mesa
+ makedepends = glu
+ makedepends = exiv2
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = python-gobject
+ depends = gegl
+ depends = lib32-babl
+ depends = lib32-libspiro
+ depends = lib32-json-glib
+ depends = lib32-libgexiv2
+ depends = lib32-libraw
+ depends = lib32-openexr
+ depends = lib32-pango
+ depends = lib32-librsvg
+ depends = lib32-libtiff
+ depends = lib32-gdk-pixbuf2
+ depends = lib32-lensfun
+ depends = lib32-v4l-utils
+ depends = lib32-luajit
+ depends = lib32-sdl2
+ depends = lib32-suitesparse
+ depends = lib32-libwebp
+ depends = lib32-ffmpeg
+ source = https://gitlab.gnome.org/GNOME/gegl/-/archive/ef8b69c06d1c4c0502a09f18bd70c5c6effe587b/gegl-ef8b69c06d1c4c0502a09f18bd70c5c6effe587b.tar.gz
+ source = x86-linux-gnu
+ source = pkgconf32
+ sha512sums = d9afe2b7f93d803f8de4c42d8d639753daba27345f338b56b662df8beeccc5eb44ad639b220cc1354f63d4d9d712a6ef77a84ef2839f95ebcb407a0c52095c35
+ sha512sums = c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5
+ sha512sums = f704e11f3054312e35974194af845e00fdc795aa97e82d425fb52ff8e628702926551b583f0354f9f9e7eafeb71c7f348c288457ff19a8c4807c58f637d0d946
+
+pkgname = lib32-gegl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ab0ea48c990
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+gegl-*.tar.gz
+lib32-gegl-*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49cf25f2e5b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Daniel Isenmann <daniel@archlinux.org>
+
+pkgname=lib32-gegl
+_pkgbase=gegl
+pkgver=0.4.20
+_commit=ef8b69c06d1c4c0502a09f18bd70c5c6effe587b # tags/GEGL_0_4_20^0
+pkgrel=1
+pkgdesc="Graph based image processing framework (32-bit)"
+arch=('x86_64')
+url="https://www.gegl.org/"
+license=('GPL3' 'LGPL3')
+depends=('gegl' 'lib32-babl' 'lib32-libspiro' 'lib32-json-glib'
+ 'lib32-libgexiv2' 'lib32-libraw' 'lib32-openexr' 'lib32-pango'
+ 'lib32-librsvg' 'lib32-libtiff' 'lib32-gdk-pixbuf2'
+ 'lib32-lensfun' 'lib32-v4l-utils' 'lib32-luajit' 'lib32-sdl2'
+ 'lib32-suitesparse' 'lib32-libwebp' 'lib32-ffmpeg')
+makedepends=('intltool' 'ruby' 'mesa' 'glu' 'exiv2' 'vala' 'gobject-introspection' 'meson' 'python-gobject')
+source=("https://gitlab.gnome.org/GNOME/$_pkgbase/-/archive/$_commit/$_pkgbase-$_commit.tar.gz"
+ "x86-linux-gnu"
+ "pkgconf32")
+sha512sums=('d9afe2b7f93d803f8de4c42d8d639753daba27345f338b56b662df8beeccc5eb44ad639b220cc1354f63d4d9d712a6ef77a84ef2839f95ebcb407a0c52095c35'
+ 'c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5'
+ 'f704e11f3054312e35974194af845e00fdc795aa97e82d425fb52ff8e628702926551b583f0354f9f9e7eafeb71c7f348c288457ff19a8c4807c58f637d0d946')
+
+prepare() {
+ cp "/usr/lib/pkgconfig/vapigen.pc" \
+ "/usr/lib/pkgconfig/gobject-introspection-1.0.pc" \
+ "/usr/lib/pkgconfig/pygobject-3.0.pc" \
+ "$srcdir/"
+}
+
+build() {
+ mkdir -p "build"
+ arch-meson "${_pkgbase}-$_commit" "build" -Dworkshop=true -Dmrg=disabled --cross-file x86-linux-gnu --libdir=/usr/lib32
+ ninja -C "build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "build" install
+ rm -r "$pkgdir/usr/"{share,include,bin}
+}
+
diff --git a/pkgconf32 b/pkgconf32
new file mode 100755
index 000000000000..517eab087305
--- /dev/null
+++ b/pkgconf32
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig:/usr/share/pkgconfig:.' /usr/bin/pkgconf $@
diff --git a/x86-linux-gnu b/x86-linux-gnu
new file mode 100644
index 000000000000..b07adf2fe607
--- /dev/null
+++ b/x86-linux-gnu
@@ -0,0 +1,18 @@
+[binaries]
+c = '/usr/bin/gcc'
+cpp = '/usr/bin/g++'
+ar = '/usr/bin/gcc-ar'
+strip = '/usr/bin/strip'
+pkgconfig = './pkgconf32'
+
+[properties]
+c_args = ['-m32']
+c_link_args = ['-m32']
+cpp_args = ['-m32']
+cpp_link_args = ['-m32']
+
+[host_machine]
+system = 'linux'
+cpu_family = 'x86'
+cpu = 'i686'
+endian = 'little'