summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosvein2015-08-12 22:17:02 +0200
committerosvein2015-08-12 22:17:02 +0200
commit1c45aa2fab1c49e78a2a612c613eafc09a0e14a5 (patch)
treee93cc6d486e6a5cba53acc90ca29fd8b2c9b2efa
downloadaur-1c45aa2fab1c49e78a2a612c613eafc09a0e14a5.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b210025b6ce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-gimp
+ pkgdesc = GNU Image Manipulation Program (32-bit)
+ pkgver = 2.8.14
+ pkgrel = 1
+ url = http://www.gimp.org/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = lib32-glibc
+ depends = lib32-cairo
+ depends = lib32-gdk-pixbuf2
+ depends = lib32-glib2
+ depends = lib32-pango
+ depends = gimp
+ source = https://www.archlinux.org/packages/extra/i686/gimp/download/#gimp-i686.pkg.tar.xz
+ md5sums = SKIP
+
+pkgname = lib32-gimp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4c9012dce6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+_pkgbase=gimp
+pkgname=lib32-gimp
+pkgver=2.8.14
+pkgrel=1
+pkgdesc="GNU Image Manipulation Program (32-bit)"
+arch=('x86_64')
+url="http://www.gimp.org/"
+depends=( 'lib32-glibc' 'lib32-cairo' 'lib32-gdk-pixbuf2' 'lib32-glib2' 'lib32-pango' 'gimp')
+license=('GPL' 'LGPL')
+source=(https://www.archlinux.org/packages/extra/i686/gimp/download/#gimp-i686.pkg.tar.xz)
+md5sums=('SKIP')
+pkgver() {
+ cat $srcdir/.PKGINFO | grep -oP '(?<=pkgver = )\d+\.\d+\.\d+'
+}
+package() {
+ mkdir -p ${pkgdir}/usr/lib32
+ cp -rPf ${srcdir}/usr/lib/*.so* ${pkgdir}/usr/lib32
+ install -dm755 "${pkgdir}"/usr/share/licenses
+ ln -s ${_pkgbase} "${pkgdir}"/usr/share/licenses/${pkgname}
+}