summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2015-12-14 22:38:07 -0500
committerLukas Sabota2015-12-14 22:38:07 -0500
commit70c572a5740b9bd69fc83622882320bee4ebfa3d (patch)
treed663b772b80c4017cf4de952835c59cc1a0e0046
downloadaur-70c572a5740b9bd69fc83622882320bee4ebfa3d.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
-rw-r--r--aclocal-fixes.patch11
-rw-r--r--gcc340.patch15
-rw-r--r--glib.install20
-rw-r--r--glib1-autotools.patch33
6 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a98958c3bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Dec 15 03:37:13 UTC 2015
+pkgbase = lib32-glib
+ pkgdesc = Common C routines used by Gtk+ and other libs (32-bit)
+ pkgver = 1.2.10
+ pkgrel = 1
+ url = http://www.gtk.org/
+ install = glib.install
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-multilib
+ depends = lib32-glibc
+ depends = sh
+ options = !makeflags
+ source = ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/glib-1.2.10.tar.gz
+ source = gcc340.patch
+ source = aclocal-fixes.patch
+ source = glib1-autotools.patch
+ sha1sums = e5a9361c594608d152d5d9650154c2e3260b87fa
+ sha1sums = a2cc224a66aeffdcac16ebd9e8af18143cf54918
+ sha1sums = ae4438cf56c0c9264ee36f6973fb445f9a820be0
+ sha1sums = 8a25fde3c79567262b3024f4e74c9ca4ee8a6279
+
+pkgname = lib32-glib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e7b9e565470
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Lukas Sabota <lukas@lwsabota.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+_pkgname=glib
+pkgname=lib32-glib
+pkgver=1.2.10
+pkgrel=1
+pkgdesc="Common C routines used by Gtk+ and other libs (32-bit)"
+arch=('x86_64')
+url="http://www.gtk.org/"
+license=('LGPL')
+depends=('lib32-glibc' 'sh')
+makedepends=('gcc-multilib')
+options=('!makeflags')
+install=glib.install
+source=(ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/${_pkgname}-${pkgver}.tar.gz
+ gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
+sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
+ 'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
+ 'ae4438cf56c0c9264ee36f6973fb445f9a820be0'
+ '8a25fde3c79567262b3024f4e74c9ca4ee8a6279')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/gcc340.patch"
+ patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
+ patch -Np1 -i "${srcdir}/glib1-autotools.patch"
+ sed -i -e 's/ifdef[[:space:]]*__OPTIMIZE__/if 0/' glib.h
+}
+
+build() {
+ export CC="gcc -m32"
+ cd ${_pkgname}-${pkgver}
+ if [[ $CARCH = "i686" ]]; then
+ CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
+ elif [[ $CARCH = "x86_64" ]]; then
+ CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+ fi
+
+ autoreconf --force --install
+ ./configure --prefix=/usr --libdir=/usr/lib32 --mandir=/usr/share/man \
+ --infodir=/usr/share/info $CONFIGFLAG
+ make
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ # Cleanup for lib32 package
+ rm -rf ${pkgdir}/usr/{include,share,bin}
+}
diff --git a/aclocal-fixes.patch b/aclocal-fixes.patch
new file mode 100644
index 000000000000..b064074aad58
--- /dev/null
+++ b/aclocal-fixes.patch
@@ -0,0 +1,11 @@
+--- glib.m4.orig 2006-03-05 13:13:24.000000000 +0000
++++ glib.m4 2006-03-05 13:13:35.000000000 +0000
+@@ -5,7 +5,7 @@
+ dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or
+ dnl gthread is specified in MODULES, pass to glib-config
+ dnl
+-AC_DEFUN(AM_PATH_GLIB,
++AC_DEFUN([AM_PATH_GLIB],
+ [dnl
+ dnl Get the cflags and libraries from the glib-config script
+ dnl
diff --git a/gcc340.patch b/gcc340.patch
new file mode 100644
index 000000000000..941111ae7d04
--- /dev/null
+++ b/gcc340.patch
@@ -0,0 +1,15 @@
+diff -Naur glib-1.2.10.orig/glib.h glib-1.2.10/glib.h
+--- glib-1.2.10.orig/glib.h 2001-02-27 04:44:38.000000000 +0100
++++ glib-1.2.10/glib.h 2004-05-27 15:50:32.436527848 +0200
+@@ -271,8 +271,10 @@
+
+ /* Wrap the gcc __PRETTY_FUNCTION__ and __FUNCTION__ variables with
+ * macros, so we can refer to them as strings unconditionally.
++ *
++ * Unfortunately these are _not_ treated as strings anymore in GCC3.4.
+ */
+-#ifdef __GNUC__
++#if defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ < 4)
+ #define G_GNUC_FUNCTION __FUNCTION__
+ #define G_GNUC_PRETTY_FUNCTION __PRETTY_FUNCTION__
+ #else /* !__GNUC__ */
diff --git a/glib.install b/glib.install
new file mode 100644
index 000000000000..c0046feba0f3
--- /dev/null
+++ b/glib.install
@@ -0,0 +1,20 @@
+infodir=usr/share/info
+filelist=(glib.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
diff --git a/glib1-autotools.patch b/glib1-autotools.patch
new file mode 100644
index 000000000000..1332c9639b28
--- /dev/null
+++ b/glib1-autotools.patch
@@ -0,0 +1,33 @@
+diff -Naur glib-1.2.10-orig/configure.in glib-1.2.10/configure.in
+--- glib-1.2.10-orig/configure.in 2013-07-22 01:33:26.930091236 -0400
++++ glib-1.2.10/configure.in 2013-07-22 01:35:19.988776415 -0400
+@@ -17,7 +17,7 @@
+
+ dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
+ dnl are available for $ac_help expansion (don't we all *love* autoconf?)
+-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
++AC_DIVERT_PUSH()dnl
+ #
+ # The following version number definitions apply to GLib, GModule and GThread
+ # as a whole, so if changes occoured in any of them, they are all
+@@ -81,7 +81,7 @@
+
+ dnl figure debugging default, prior to $ac_help setup
+ dnl
+-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
++AC_DIVERT_PUSH()dnl
+ if test `expr $GLIB_MINOR_VERSION \% 2` = 1 ; then
+ debug_default=yes
+ else
+diff -Naur glib-1.2.10-orig/gmodule/Makefile.am glib-1.2.10/gmodule/Makefile.am
+--- glib-1.2.10-orig/gmodule/Makefile.am 2013-07-22 01:33:26.933424531 -0400
++++ glib-1.2.10/gmodule/Makefile.am 2013-07-22 01:38:46.553041607 -0400
+@@ -42,7 +42,7 @@
+ libgplugin_b_la_LIBADD = @G_MODULE_LIBS@ # $(libglib)
+
+ noinst_PROGRAMS = testgmodule
+-testgmodule_LDFLAGS += @G_MODULE_LDFLAGS@
++testgmodule_LDFLAGS = @G_MODULE_LDFLAGS@
+ testgmodule_LDADD = libgmodule.la $(libglib) @G_MODULE_LIBS@
+
+ .PHONY: files release