summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2023-07-21 20:13:59 -0400
committerAlexandre Demers2023-08-12 02:01:07 -0400
commit9633a9c77ea4c2ba8c04278fa715aa1350c5379f (patch)
treecea67b30c88c83f237edda2b93e17ccc5eb24170
parentc67fe07ea600cab2077726bc63244b7bfc7c6fe6 (diff)
downloadaur-9633a9c77ea4c2ba8c04278fa715aa1350c5379f.tar.gz
Update to 12.3.1 and deactivate build test
If we assume the build test was run before tag the release and if we add on it that the native package runs the build test, it is probably safe to deactivate the build test. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c11368aae35b..440ebe3ceb6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-glslang
pkgdesc = OpenGL and OpenGL ES shader front end and validator (32bit)
- pkgver = 12.2.0
+ pkgver = 12.3.1
pkgrel = 1
url = https://github.com/KhronosGroup/glslang
arch = x86_64
@@ -10,12 +10,14 @@ pkgbase = lib32-glslang
makedepends = git
makedepends = lib32-spirv-tools
makedepends = spirv-headers
- depends = glslang>=12.2.0
+ depends = glslang>=12.3.1
depends = lib32-glibc
depends = lib32-gcc-libs
depends = python
options = staticlibs
- source = lib32-glslang-12.2.0.tar.gz::https://github.com/KhronosGroup/glslang/archive/12.2.0.tar.gz
- sha256sums = 870d17030fda7308c1521fb2e01a9e93cbe4b130bc8274e90d00e127432ab6f6
+ source = lib32-glslang-12.3.1.tar.gz::https://github.com/KhronosGroup/glslang/archive/12.3.1.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/3283.patch
+ sha256sums = a57836a583b3044087ac51bb0d5d2d803ff84591d55f89087fc29ace42a8b9a8
+ sha256sums = 267b65a5205315e980f077f5fa401223003fdb5a38162e6ae697d38f68115137
pkgname = lib32-glslang
diff --git a/PKGBUILD b/PKGBUILD
index 96abdcc0aa87..f528ae4a138a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _setFullLibdir="${_setPrefix}/${_setLibdir}"
_pkgbasename=glslang
pkgname=lib32-$_pkgbasename
-pkgver=12.2.0
+pkgver=12.3.1
pkgrel=1
pkgdesc='OpenGL and OpenGL ES shader front end and validator (32bit)'
arch=('x86_64')
@@ -35,12 +35,20 @@ makedepends=(
'spirv-headers'
)
options=('staticlibs')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz)
-sha256sums=('870d17030fda7308c1521fb2e01a9e93cbe4b130bc8274e90d00e127432ab6f6')
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/3283.patch
+)
+sha256sums=(
+ 'a57836a583b3044087ac51bb0d5d2d803ff84591d55f89087fc29ace42a8b9a8'
+ '267b65a5205315e980f077f5fa401223003fdb5a38162e6ae697d38f68115137'
+ )
prepare() {
echo "Patching if needed"
cd ${_pkgbasename}-${pkgver}
+
+ patch -Np1 -i "$srcdir"/3283.patch
}
build() {
@@ -58,7 +66,8 @@ build() {
-DCMAKE_INSTALL_LIBDIR="lib32" \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS:STRING=-m32 \
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=OFF
ninja -Cbuild-shared
cmake \
@@ -68,13 +77,14 @@ build() {
-DCMAKE_INSTALL_LIBDIR="lib32" \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS:STRING=-m32 \
- -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_SHARED_LIBS=OFF \
+ -DBUILD_TESTING=OFF
ninja -Cbuild-static
}
check() {
cd ${_pkgbasename}-${pkgver}
- ninja -Cbuild-shared test
+# ninja -Cbuild-shared test
}
package() {