summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2023-04-02 23:28:53 -0400
committerAlexandre Demers2023-04-02 23:28:53 -0400
commitaa07665c80d2bbed76998c158a929311bdef8f48 (patch)
tree773449a65bec6807702f7b5cdb5cf67c81bec4a7
parentc348620b9782e1559445b84071b557f96518b324 (diff)
downloadaur-aa07665c80d2bbed76998c158a929311bdef8f48.tar.gz
Upgrade to 12.1.0
It includes all modifications from native package since 11.10.0. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba61ec71698b..36d472ce725a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-glslang
pkgdesc = OpenGL and OpenGL ES shader front end and validator (32bit)
- pkgver = 11.10.0
+ pkgver = 12.1.0
pkgrel = 1
url = https://github.com/KhronosGroup/glslang
arch = x86_64
@@ -8,13 +8,14 @@ pkgbase = lib32-glslang
makedepends = cmake
makedepends = ninja
makedepends = git
- makedepends = python
makedepends = lib32-spirv-tools
makedepends = spirv-headers
- depends = glslang>=11.10.0
+ depends = glslang>=12.1.0
+ depends = lib32-glibc
depends = lib32-gcc-libs
+ depends = python
options = staticlibs
- source = lib32-glslang-11.10.0.tar.gz::https://github.com/KhronosGroup/glslang/archive/11.10.0.tar.gz
- sha256sums = 8ffc19c435232d09299dd2c91e247292b3508c1b826a3497c60682e4bbf2d602
+ source = lib32-glslang-12.1.0.tar.gz::https://github.com/KhronosGroup/glslang/archive/12.1.0.tar.gz
+ sha256sums = 1515e840881d1128fb6d831308433f731808f818f2103881162f3ffd47b15cd5
pkgname = lib32-glslang
diff --git a/PKGBUILD b/PKGBUILD
index 9af4e167f283..2e33b1ea7ad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,21 @@
# Maintainer: Alexandre Demers <alexandre.f.demers@gmail.com>
-# Careful when upgrading this package! It usually breaks ABI without bumping soname.
+# Careful when upgrading this package! It usually breaks ABI without bumping
+# soname. Also, be very mindful of the version of spirv-tools that this links
+# to. Upstream actually expects the use of the particular commits of
+# spirv-tools and spirv-headers that are provided in known_good.json. However,
+# if we went that route, we'd have to vendor the resulting spirv-tools libs
+# from this glslang build and they would be incompatible with system libs,
+# resulting in us having to ship both. Instead, I recommend just waiting until
+# upstream releases a compatible version of spirv-tools, then updating the
+# spriv-tools system package and only then building glslang against that.
_setPrefix="/usr"
_setLibdir="lib32"
_setFullLibdir="${_setPrefix}/${_setLibdir}"
_pkgbasename=glslang
pkgname=lib32-$_pkgbasename
-pkgver=11.10.0
+pkgver=12.1.0
pkgrel=1
pkgdesc='OpenGL and OpenGL ES shader front end and validator (32bit)'
arch=('x86_64')
@@ -15,19 +23,20 @@ url='https://github.com/KhronosGroup/glslang'
license=('BSD')
depends=(
"$_pkgbasename>=$pkgver"
+ 'lib32-glibc'
'lib32-gcc-libs'
+ 'python'
)
makedepends=(
'cmake'
'ninja'
'git'
- 'python'
'lib32-spirv-tools'
'spirv-headers'
)
options=('staticlibs')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz)
-sha256sums=('8ffc19c435232d09299dd2c91e247292b3508c1b826a3497c60682e4bbf2d602')
+sha256sums=('1515e840881d1128fb6d831308433f731808f818f2103881162f3ffd47b15cd5')
prepare() {
echo "Patching if needed"
@@ -40,13 +49,14 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd ${_pkgbasename}-${pkgver}
+ # we need fat LTO objects to not break consumers during linking
export CXXFLAGS+=" -ffat-lto-objects"
cmake \
-Bbuild-shared \
-G Ninja \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib32" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS:STRING=-m32 \
-DBUILD_SHARED_LIBS=ON
ninja -Cbuild-shared
@@ -56,12 +66,17 @@ build() {
-G Ninja \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib32" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS:STRING=-m32 \
-DBUILD_SHARED_LIBS=OFF
ninja -Cbuild-static
}
+check() {
+ cd ${_pkgbasename}-${pkgver}
+ ninja -Cbuild-shared test
+}
+
package() {
cd ${_pkgbasename}-${pkgver}
DESTDIR="${pkgdir}" ninja -C build-shared install