summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-06-08 19:21:57 +0200
committerFadeMind2015-06-08 19:21:57 +0200
commitad127ed8f045681eb699fa7f789550dbeb7ad162 (patch)
tree0bcede1f08e1e7e882a4ac603030b8f8cd738a26
downloadaur-ad127ed8f045681eb699fa7f789550dbeb7ad162.tar.gz
5.1.3-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5984ac26d20f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-gmp4
+ pkgdesc = Legacy version of gmp. Provides libgmp.so.3 (32 bit)
+ pkgver = 5.1.3
+ pkgrel = 1
+ url = http://gmplib.org/
+ arch = x86_64
+ license = LGPL3
+ makedepends = gcc-multilib
+ depends = lib32-gcc-libs
+ depends = sh
+ depends = lib32-gmp
+ options = !libtool
+ source = ftp://ftp.gnu.org/gnu/gmp/gmp-5.1.3.tar.bz2
+ md5sums = a082867cbca5e898371a97bb27b31fea
+
+pkgname = lib32-gmp4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f14c3fc6e47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sudowoodo <sudowoodoarch@gmail.com>
+# Contributor: Xemertix <arch88(at)katamail(dot)com>
+
+pkgname=lib32-gmp4
+pkgver=5.1.3
+pkgrel=1
+pkgdesc="Legacy version of gmp. Provides libgmp.so.3 (32 bit)"
+arch=('x86_64')
+url="http://gmplib.org/"
+depends=('lib32-gcc-libs' 'sh' 'lib32-gmp')
+makedepends=('gcc-multilib')
+license=('LGPL3')
+options=('!libtool')
+source=(ftp://ftp.gnu.org/gnu/gmp/gmp-${pkgver}.tar.bz2)
+md5sums=('a082867cbca5e898371a97bb27b31fea')
+
+prepare(){
+ cd gmp-${pkgver}
+ #Put gmp.h in the same folder as gmpxx.h
+ sed -i 's/$(exec_prefix)\/include/$\(includedir\)/' Makefile.in
+}
+
+build() {
+ export ABI='32'
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd gmp-${pkgver}
+ ./configure --prefix=/usr --libdir=/usr/lib32 \
+ --includedir=/usr/lib32/gmp --enable-cxx
+ make
+}
+
+package() {
+ cd gmp-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ #remove files that conflict with 'gmp' and 'lib32-gmp'
+ rm -rf "${pkgdir}"/usr/share
+ rm -rf "${pkgdir}"/usr/lib32/gmp
+ rm -rf "${pkgdir}"/usr/lib32/libgmp.{a,so{,.10}}
+ rm -rf "${pkgdir}"/usr/lib32/libgmpxx.{a,so{,.4}}
+
+}