summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2018-03-25 15:38:26 +0300
committerStelios Tsampas2018-03-25 15:38:26 +0300
commit579ce4bcb23861be24176c8bed44d07f63b9a9e9 (patch)
tree428c0dcc88e23f2a3de26fb112312c6e81a49334
downloadaur-579ce4bcb23861be24176c8bed44d07f63b9a9e9.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e11efec792b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lib32-gnome-themes-extra
+ pkgdesc = Extra Themes for GNOME Applications (32-bit)
+ pkgver = 3.28
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/gnome-themes-extra
+ arch = x86_64
+ groups = gnome
+ license = LGPL2.1
+ makedepends = intltool
+ makedepends = lib32-gtk2
+ makedepends = lib32-gtk3
+ makedepends = git
+ depends = cantarell-fonts
+ depends = gnome-themes-extra
+ optdepends = lib32-gtk-engines: HighContrast GTK2 theme
+ provides = lib32-gnome-themes-standard=3.28
+ conflicts = lib32-gnome-themes-standard
+ replaces = lib32-gnome-themes-standard<3.27.92
+ source = git+https://gitlab.gnome.org/GNOME/gnome-themes-extra.git#commit=9f581269243dd7e76b3eb8cec9cf4128ab17da9e
+ sha256sums = SKIP
+
+pkgname = lib32-gnome-themes-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..507ea460d75b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Stelios Tsampas <loathingkernel @at gmail .dot com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=lib32-gnome-themes-extra
+pkgver=3.28
+pkgrel=1
+pkgdesc="Extra Themes for GNOME Applications (32-bit)"
+url="https://gitlab.gnome.org/GNOME/gnome-themes-extra"
+arch=(x86_64)
+license=(LGPL2.1)
+depends=(cantarell-fonts ${pkgname#lib32-})
+makedepends=(intltool lib32-gtk2 lib32-gtk3 git)
+optdepends=('lib32-gtk-engines: HighContrast GTK2 theme')
+provides=("lib32-gnome-themes-standard=$pkgver")
+conflicts=(lib32-gnome-themes-standard)
+replaces=('lib32-gnome-themes-standard<3.27.92')
+groups=(gnome)
+_commit=9f581269243dd7e76b3eb8cec9cf4128ab17da9e # tags/3.28^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-themes-extra.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname#lib32-}
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd ${pkgname#lib32-}
+ mkdir m4
+ intltoolize
+ autoreconf -fvi
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd ${pkgname#lib32-}
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd ${pkgname#lib32-}
+ make DESTDIR="$pkgdir" install
+ # remove unneeded stuff
+ rm -fr ${pkgdir}/{usr/{bin,include,share},etc}
+}
+
+# vim:set ts=2 sw=2 et: