summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Boswell2015-06-26 15:29:10 -0400
committerMatt Boswell2015-06-26 15:29:10 -0400
commit0bcc658cc25f23aec3158c043503472e33bf320a (patch)
tree052e27caad4996e02ef25411e5a1d61fc78f8163
downloadaur-lib32-gnome-vfs.tar.gz
Initial import
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD65
-rw-r--r--enable-deprecated.patch57
-rw-r--r--gcrypt-config.patch31
-rw-r--r--gnutls-3.4.0.patch38
-rw-r--r--gnutls-config.patch25
6 files changed, 256 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..6969c59d39a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by makepkg 4.2.1
+# Fri May 22 03:33:16 UTC 2015
+pkgbase = lib32-gnome-vfs
+ pkgdesc = The GNOME Virtual File System (32 bit)
+ pkgver = 2.24.4
+ pkgrel = 11
+ url = http://www.gnome.org
+ arch = x86_64
+ license = LGPL
+ makedepends = gnome-mime-data
+ makedepends = pkgconfig
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gnome-common
+ makedepends = lib32-dbus-glib
+ makedepends = lib32-keyutils
+ depends = gnome-vfs
+ depends = lib32-gconf
+ depends = lib32-bzip2
+ depends = lib32-avahi
+ depends = lib32-smbclient
+ depends = lib32-krb5
+ depends = lib32-gnutls
+ depends = lib32-libgcrypt
+ options = !libtool
+ options = !emptydirs
+ options = !docs
+ source = http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/2.24/gnome-vfs-2.24.4.tar.bz2
+ source = gnutls-config.patch
+ source = gnutls-3.4.0.patch
+ source = gcrypt-config.patch
+ source = enable-deprecated.patch
+ sha256sums = 62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa
+ sha256sums = 66c7cfb12995c0dd94a2caea95c7e3c55981993f05a79c585d60915ff131955d
+ sha256sums = 5fe5e2e1ad8d8d36deb2d38db621d5b8350aafe3876f722467465c3b3fa304d3
+ sha256sums = c059e218f310da683778919d36e7862f7e763384805f6453d328fbaf507a8114
+ sha256sums = ca2b9dffb1fa202c0d1f0d3648ef37cd8e84657a22d4c6746bb46e9a6cf1ee47
+
+pkgname = lib32-gnome-vfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..a1ac1144458
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Matt Boswell <mordervomubel+archlinux at lockmail.us>
+# Previous Maintainer: josephgbr <rafael.f.f1 at gmail dot com>
+
+_pkgbase=gnome-vfs
+pkgname=lib32-$_pkgbase
+pkgver=2.24.4
+pkgrel=11
+pkgdesc="The GNOME Virtual File System (32 bit)"
+arch=('x86_64')
+license=('LGPL')
+depends=('gnome-vfs' 'lib32-gconf' 'lib32-bzip2' 'lib32-avahi' 'lib32-smbclient' 'lib32-krb5' 'lib32-gnutls' 'lib32-libgcrypt')
+makedepends=('gnome-mime-data' 'pkgconfig' 'intltool' 'gtk-doc' 'gnome-common' 'lib32-dbus-glib' 'lib32-keyutils')
+options=('!libtool' '!emptydirs' '!docs')
+url="http://www.gnome.org"
+source=(http://ftp.gnome.org/pub/gnome/sources/${_pkgbase}/2.24/$_pkgbase-${pkgver}.tar.bz2
+ gnutls-config.patch
+ gnutls-3.4.0.patch
+ gcrypt-config.patch
+ enable-deprecated.patch)
+sha256sums=('62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa'
+ '66c7cfb12995c0dd94a2caea95c7e3c55981993f05a79c585d60915ff131955d'
+ '5fe5e2e1ad8d8d36deb2d38db621d5b8350aafe3876f722467465c3b3fa304d3'
+ 'c059e218f310da683778919d36e7862f7e763384805f6453d328fbaf507a8114'
+ 'ca2b9dffb1fa202c0d1f0d3648ef37cd8e84657a22d4c6746bb46e9a6cf1ee47')
+
+prepare() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ #Fix build with new gnutls
+ patch -Np1 -i ../gnutls-config.patch
+ patch -Np1 -i ../gnutls-3.4.0.patch
+ #fix build with new libgcrypt >= 1.5.0
+ patch -Np1 -i ../gcrypt-config.patch
+ # remove -DG_DISABLE_DEPRECATED
+ patch -Np1 -i ../enable-deprecated.patch
+
+ sed -i -s 's|$(srcdir)/auto-test|auto-test|' test/Makefile.am
+}
+build() {
+ export CC='gcc -m32 -Dg_memmove=memmove'
+ export CXX='g++ -m32 -Dg_memmove=memmove'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ libtoolize --force
+ gtkdocize
+ aclocal
+ autoconf
+ automake --add-missing
+ CFLAGS="$CFLAGS -fno-strict-aliasing" ./configure \
+ --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib32/gnome-vfs-2.0 \
+ --enable-samba --with-samba-includes=/usr/include/samba-4.0 \
+ --disable-hal --enable-avahi --disable-howl \
+ --disable-openssl --enable-gnutls \
+ --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+ rm -rf ${pkgdir}/{etc,usr/{bin,include,share}}
+}
diff --git a/enable-deprecated.patch b/enable-deprecated.patch
new file mode 100644
index 00000000000..0f249b2bbe7
--- /dev/null
+++ b/enable-deprecated.patch
@@ -0,0 +1,57 @@
+diff -up gnome-vfs-2.24.4/daemon/Makefile.am.bak gnome-vfs-2.24.4/daemon/Makefile.am
+--- gnome-vfs-2.24.4/daemon/Makefile.am.bak 2010-02-09 13:16:14.000000000 +0100
++++ gnome-vfs-2.24.4/daemon/Makefile.am 2013-03-27 17:01:25.000000000 +0100
+@@ -8,7 +8,6 @@ INCLUDES= \
+ -D_LARGEFILE64_SOURCE \
+ -D_POSIX_PTHREAD_SEMANTICS \
+ -D_REENTRANT \
+- -DG_DISABLE_DEPRECATED \
+ -DGNOME_VFS_PREFIX=\"$(prefix)\" \
+ -DGNOME_VFS_DATADIR=\"$(datadir)\" \
+ -DGNOME_VFS_LIBDIR=\"$(libdir)\" \
+diff -up gnome-vfs-2.24.4/libgnomevfs/Makefile.am.bak gnome-vfs-2.24.4/libgnomevfs/Makefile.am
+--- gnome-vfs-2.24.4/libgnomevfs/Makefile.am.bak 2010-02-09 13:16:14.000000000 +0100
++++ gnome-vfs-2.24.4/libgnomevfs/Makefile.am 2013-03-27 17:01:37.000000000 +0100
+@@ -19,7 +19,6 @@ INCLUDES = \
+ -D_LARGEFILE64_SOURCE \
+ -D_POSIX_PTHREAD_SEMANTICS \
+ -D_REENTRANT \
+- -DG_DISABLE_DEPRECATED \
+ -DGNOME_VFS_PREFIX=\"$(prefix)\" \
+ -DGNOME_VFS_BINDIR=\"$(bindir)\" \
+ -DGNOME_VFS_DATADIR=\"$(datadir)\" \
+diff -up gnome-vfs-2.24.4/modules/Makefile.am.bak gnome-vfs-2.24.4/modules/Makefile.am
+--- gnome-vfs-2.24.4/modules/Makefile.am.bak 2010-02-09 13:16:14.000000000 +0100
++++ gnome-vfs-2.24.4/modules/Makefile.am 2013-03-27 17:01:45.000000000 +0100
+@@ -18,7 +18,6 @@ INCLUDES = \
+ -D_POSIX_PTHREAD_SEMANTICS \
+ -D_REENTRANT \
+ -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" \
+- -DG_DISABLE_DEPRECATED \
+ -DGNOME_VFS_PREFIX=\"$(prefix)\" \
+ -DGNOME_VFS_DATADIR=\"$(datadir)\" \
+ -DGNOME_VFS_LIBDIR=\"$(libdir)\" \
+diff -up gnome-vfs-2.24.4/programs/Makefile.am.bak gnome-vfs-2.24.4/programs/Makefile.am
+--- gnome-vfs-2.24.4/programs/Makefile.am.bak 2010-02-09 13:16:14.000000000 +0100
++++ gnome-vfs-2.24.4/programs/Makefile.am 2013-03-27 17:01:56.000000000 +0100
+@@ -4,8 +4,7 @@ INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(TEST_CFLAGS) \
+- $(VFS_CFLAGS) \
+- -DG_DISABLE_DEPRECATED
++ $(VFS_CFLAGS)
+
+ libraries = \
+ $(top_builddir)/libgnomevfs/libgnomevfs-2.la \
+diff -up gnome-vfs-2.24.4/test/Makefile.am.bak gnome-vfs-2.24.4/test/Makefile.am
+--- gnome-vfs-2.24.4/test/Makefile.am.bak 2013-03-27 17:01:11.000000000 +0100
++++ gnome-vfs-2.24.4/test/Makefile.am 2013-03-27 17:02:08.000000000 +0100
+@@ -6,7 +6,6 @@ INCLUDES = \
+ -I$(top_builddir)/libgnomevfs \
+ $(TEST_CFLAGS) \
+ $(VFS_CFLAGS) \
+- -DG_DISABLE_DEPRECATED \
+ -DMODULES_PATH=\"$(libdir)/vfs/modules\"
+
+ if OS_WIN32
diff --git a/gcrypt-config.patch b/gcrypt-config.patch
new file mode 100644
index 00000000000..8ce91870aeb
--- /dev/null
+++ b/gcrypt-config.patch
@@ -0,0 +1,31 @@
+# Allow gnome-vfs-2.24 to build with libgcrypt >= 1.5.0
+--- gnome-vfs-2.24.4/configure.in 2010-07-01 12:36:09.000000000 -0300
++++ gnome-vfs-2.24.4-libgcrypt//configure.in 2011-07-22 15:55:02.296325640 -0300
+@@ -689,6 +689,16 @@
+ AM_CONDITIONAL(HAVE_SSL, test x$have_ssl = xtrue)
+
+ dnl ****************************
++dnl LibGCrypt 1.5.0
++dnl ****************************
++
++AM_PATH_LIBGCRYPT(1.5.0)
++
++if test "x${LIBGCRYPT_LIBS}" = "x"; then
++ AC_MSG_ERROR([unable to find libgcrypt])
++fi
++
++dnl ****************************
+ dnl DNS-SD implementations
+ dnl ****************************
+ AM_CONDITIONAL(HAVE_AVAHI, false)
+@@ -1045,8 +1055,8 @@
+ dnl ==============================================================================
+
+ PKG_CHECK_MODULES(LIBGNOMEVFS, glib-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED gthread-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libxml-2.0 >= $XML_REQUIRED gnome-mime-data-2.0 $dbus_requirement)
+-LIBGNOMEVFS_CFLAGS="$LIBGNOMEVFS_CFLAGS $OPENSSL_CFLAGS $LIBGNUTLS_CFLAGS $HOWL_CFLAGS $AVAHI_CFLAGS"
+-LIBGNOMEVFS_LIBS="$LIBGNOMEVFS_LIBS $OPENSSL_LIBS $LIBGNUTLS_LIBS $HOWL_LIBS $AVAHI_LIBS $RESOLVER_LIBS"
++LIBGNOMEVFS_CFLAGS="$LIBGNOMEVFS_CFLAGS $OPENSSL_CFLAGS $LIBGNUTLS_CFLAGS $HOWL_CFLAGS $AVAHI_CFLAGS $LIBGCRYPT_CFLAGS"
++LIBGNOMEVFS_LIBS="$LIBGNOMEVFS_LIBS $OPENSSL_LIBS $LIBGNUTLS_LIBS $HOWL_LIBS $AVAHI_LIBS $RESOLVER_LIBS $LIBGCRYPT_LIBS"
+ AC_SUBST(LIBGNOMEVFS_CFLAGS)
+ AC_SUBST(LIBGNOMEVFS_LIBS)
+
diff --git a/gnutls-3.4.0.patch b/gnutls-3.4.0.patch
new file mode 100644
index 00000000000..78942f06ea1
--- /dev/null
+++ b/gnutls-3.4.0.patch
@@ -0,0 +1,38 @@
+diff -uprw gnome-vfs-2.24.4.orig/libgnomevfs/gnome-vfs-ssl.c gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c
+--- gnome-vfs-2.24.4.orig/libgnomevfs/gnome-vfs-ssl.c 2010-02-09 14:16:14.000000000 +0200
++++ gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c 2015-04-14 00:01:51.272451668 +0300
+@@ -314,21 +314,6 @@ gnome_vfs_ssl_create (GnomeVFSSSL **hand
+ #endif
+ }
+
+-#ifdef HAVE_GNUTLS
+-static const int protocol_priority[] = {GNUTLS_TLS1, GNUTLS_SSL3, 0};
+-static const int cipher_priority[] =
+- {GNUTLS_CIPHER_RIJNDAEL_128_CBC, GNUTLS_CIPHER_3DES_CBC,
+- GNUTLS_CIPHER_RIJNDAEL_256_CBC, GNUTLS_CIPHER_ARCFOUR, 0};
+-static const int comp_priority[] =
+- {GNUTLS_COMP_ZLIB, GNUTLS_COMP_NULL, 0};
+-static const int kx_priority[] =
+- {GNUTLS_KX_DHE_RSA, GNUTLS_KX_RSA, GNUTLS_KX_DHE_DSS, 0};
+-static const int mac_priority[] =
+- {GNUTLS_MAC_SHA, GNUTLS_MAC_MD5, 0};
+-
+-#endif
+-
+-
+ /**
+ * gnome_vfs_ssl_create_from_fd:
+ * @handle_return: pointer to a #GnomeVFSSSL struct, which will
+@@ -437,11 +422,7 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
+ gnutls_transport_set_ptr (ssl->private->tlsstate,
+ GINT_TO_POINTER (fd));
+
+- gnutls_protocol_set_priority (ssl->private->tlsstate, protocol_priority);
+- gnutls_cipher_set_priority (ssl->private->tlsstate, cipher_priority);
+- gnutls_compression_set_priority (ssl->private->tlsstate, comp_priority);
+- gnutls_kx_set_priority (ssl->private->tlsstate, kx_priority);
+- gnutls_mac_set_priority (ssl->private->tlsstate, mac_priority);
++ gnutls_set_default_priority (ssl->private->tlsstate);
+
+ gnutls_cred_set (ssl->private->tlsstate, GNUTLS_CRD_CERTIFICATE,
+ ssl->private->xcred);
diff --git a/gnutls-config.patch b/gnutls-config.patch
new file mode 100644
index 00000000000..f6fa18b1790
--- /dev/null
+++ b/gnutls-config.patch
@@ -0,0 +1,25 @@
+# Allow gnome-vfs-2.24 to build with gnutls >= 2.7.0
+# Use pkg-config in place of gnutls own macro since it's not present anymore.
+--- a/configure.in 2009-03-07 19:59:53.805507753 +0100
++++ b/configure.in 2009-03-07 18:34:36.928169018 +0100
+@@ -686,14 +686,14 @@
+ AC_MSG_ERROR([*** Can't use both openssl and gnutls at the same time. Please pick one only. ***])
+ else
+ AC_CHECK_HEADER(gcrypt.h,, AC_MSG_ERROR([*** Need gcrypt.h to compile with GnuTLS support ***]))
+- AM_PATH_LIBGNUTLS(1.0.0, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
+- have_ssl=true])
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 1.0.0, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
++ have_ssl=true])
+
+ if test "x${LIBGNUTLS_LIBS}" = "x"; then
+- AM_PATH_LIBGNUTLS(0.5.1, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
+- AC_DEFINE(GNUTLS_COMPAT, 1, [FIXME])
+- have_ssl=true],
+- AC_MSG_ERROR([Unable to find GNUTLS]))
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 0.5.1, [AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if GnuTLS is available])
++ AC_DEFINE(GNUTLS_COMPAT, 1, [FIXME])
++ have_ssl=true],
++ AC_MSG_ERROR([Unable to find GNUTLS]))
+ fi
+ fi
+ fi