summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaansu2017-01-10 18:16:26 -0800
committerRaansu2017-01-10 18:16:26 -0800
commit96a3f1866f40a68d6c11f0637b68b88d2823373a (patch)
tree8f07b0f1ab46a0db0d3b9d1232c915ff524eabe8
downloadaur-96a3f1866f40a68d6c11f0637b68b88d2823373a.tar.gz
Initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6711d123a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-gnutls26
+ pkgdesc = gnutls26 library (current maintained debian version with .so-version 26) This is the Multilib package.
+ pkgver = 2.12.20
+ pkgrel = 8
+ url = http://www.gnutls.org/
+ arch = x86_64
+ license = LGPL3
+ depends = libgcrypt15
+ depends = libtasn1-3
+ depends = p11-kit
+ provides = lib32-gnutls26
+ conflicts = lib32-gnutls26
+ source = http://security.debian.org/debian-security/pool/updates/main/g/gnutls26//libgnutls26_2.12.20-8+deb7u5_i386.deb
+ md5sums = 08380f92802253f935415bf011f04035
+
+pkgname = lib32-gnutls26
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c61c22311fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Raansu <gero3977@gmail.com>
+
+# PKGBUILD script initially copied from https://aur.archlinux.org/packages/libgnutls26/
+# Contributor: Uwe Koloska <kolewu@koloro.de>
+# Contributor: Sairon Istyar <saironiq@gmail.com>
+
+pkgname=lib32-gnutls26
+pkgver=2.12.20
+_sover=26.22.4
+pkgrel=8
+pkgdesc='gnutls26 library (current maintained debian version with
+.so-version 26) This is the Multilib package.'
+arch=('x86_64')
+url="http://www.gnutls.org/"
+license=('LGPL3')
+depends=('libgcrypt15' 'libtasn1-3' 'p11-kit')
+provides=('lib32-gnutls26')
+conflicts=('lib32-gnutls26')
+
+_debver=deb7u5
+_debpkgname=libgnutls26
+_deburl="http://security.debian.org/debian-security/pool/updates/main/g/gnutls26/"
+
+if [ "${CARCH}" = "x86_64" ] ; then
+ _arch="amd64"
+ _arch2="x86_64"
+ _lib32="i386"
+else
+ _arch="i386"
+ _arch2="i386"
+fi
+
+source=(${_deburl}/${_debpkgname}_${pkgver}-${pkgrel}+${_debver}_i386.deb)
+md5sums=('08380f92802253f935415bf011f04035')
+
+package() {
+ if [ "${_arch2}" = "i386" ] ; then
+ echo "Install failed, this package is ment for multilib x86_64 systems 64bit."
+ fi
+ ar vx $srcdir/${_debpkgname}_${pkgver}-${pkgrel}+${_debver}_${_lib32}.deb
+ tar xvf $srcdir/data.tar.gz
+ install -d $pkgdir/usr/lib32/
+ cp -a $srcdir/usr/lib/${_lib32}-linux-gnu/* $pkgdir/usr/lib32/
+}