summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2015-03-18 08:29:02 +0800
committerAllen Zhong2015-03-18 08:29:02 +0800
commit93fba06b0d298f82a173fc903d764289f2729616 (patch)
treec03dfbf5ea5556b9fbf5b2614bb35645216539f7
parentd3b1a3582835630d74d68627502b2b314d246c8b (diff)
downloadaur-93fba06b0d298f82a173fc903d764289f2729616.tar.gz
upgpkg: lib32-gperftools 2.4-1
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adc7ee61f9df..2c648c3a0c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
_basename=gperftools
pkgname=lib32-$_basename
-pkgver=2.2
+pkgver=2.4
pkgrel=1
-pkgdesc="Fast, multi-threaded malloc() and nifty performance analysis tools (32-bit)"
+pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools (32-bit)"
arch=('x86_64')
url="http://code.google.com/p/gperftools/"
license=('BSD')
@@ -17,27 +17,21 @@ provides=('libtcmalloc.so'
'libtcmalloc_minimal.so'
'libtcmalloc_minimal_debug.so')
makedepends=('gcc-multilib' 'git')
-source=("git+https://code.google.com/p/gperftools#tag=gperftools-$pkgver")
-sha256sums=('SKIP')
-
-prepare() {
- cd "$_basename"
-
- ./autogen.sh
-}
+source=("https://googledrive.com/host/0B6NtGsLhIcf7MWxMMF9JdTN3UVk/$_basename-$pkgver.tar.gz")
+sha256sums=('982a37226eb42f40714e26b8076815d5ea677a422fb52ff8bfca3704d9c30a2d')
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
- cd "$_basename"
+ cd "$_basename-$pkgver"
./configure --prefix=/usr --libdir=/usr/lib32 --enable-frame-pointers
make
}
package() {
- cd "$_basename"
+ cd "$_basename-$pkgver"
# not needed in 32-bit package
make DESTDIR="$pkgdir" install