summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2016-04-25 17:33:02 +0800
committerAllen Zhong2016-04-25 17:33:02 +0800
commite8ee1eec7936d8e0d7b3131ed97e47307bef9813 (patch)
tree50c01122a503c44b351a01571713a26d424cbd27
parent93fba06b0d298f82a173fc903d764289f2729616 (diff)
downloadaur-e8ee1eec7936d8e0d7b3131ed97e47307bef9813.tar.gz
upgpkg: lib32-gperftools 2.5-1
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 41090f13b8e3..0fc4652d6ca4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,19 @@
gperftools/
+build/
+test/
+src/
+pkg/
+*.xz
+*.gz
+*.zip
+*.bz2
+*.tgz
+*.sig
+*.asc
+*.swp
+
+*.c
+*.cpp
+*.h
+*.hpp
+*.o
diff --git a/PKGBUILD b/PKGBUILD
index 2c648c3a0c04..184391328ccd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
_basename=gperftools
pkgname=lib32-$_basename
-pkgver=2.4
+pkgver=2.5
pkgrel=1
pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools (32-bit)"
arch=('x86_64')
-url="http://code.google.com/p/gperftools/"
+url="https://github.com/gperftools/gperftools"
license=('BSD')
depends=('gperftools' 'lib32-gcc-libs')
provides=('libtcmalloc.so'
@@ -17,21 +17,27 @@ provides=('libtcmalloc.so'
'libtcmalloc_minimal.so'
'libtcmalloc_minimal_debug.so')
makedepends=('gcc-multilib' 'git')
-source=("https://googledrive.com/host/0B6NtGsLhIcf7MWxMMF9JdTN3UVk/$_basename-$pkgver.tar.gz")
-sha256sums=('982a37226eb42f40714e26b8076815d5ea677a422fb52ff8bfca3704d9c30a2d')
+source=("git+https://github.com/gperftools/gperftools#tag=$_basename-$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$_basename"
+
+ ./autogen.sh
+}
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
- cd "$_basename-$pkgver"
+ cd "$_basename"
./configure --prefix=/usr --libdir=/usr/lib32 --enable-frame-pointers
make
}
package() {
- cd "$_basename-$pkgver"
+ cd "$_basename"
# not needed in 32-bit package
make DESTDIR="$pkgdir" install