summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2016-06-06 16:52:05 +0900
committerorumin2016-06-06 16:52:05 +0900
commit8b2cbb20b76d88708c6e742f72f85ccbb0aac928 (patch)
treef45bde03a04438561d0da981826fade79c268e8f
downloadaur-8b2cbb20b76d88708c6e742f72f85ccbb0aac928.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a02e85a863f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jun 6 07:51:59 UTC 2016
+pkgbase = lib32-graphene
+ pkgdesc = A thin layer of graphic data types
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/ebassi/graphene
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gobject-introspection
+ depends = lib32-glib2
+ source = git+https://github.com/ebassi/graphene#tag=1.4.0
+ md5sums = SKIP
+
+pkgname = lib32-graphene
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..736e0f57e3e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: orumin <dev@orum.in>
+
+_basename=graphene
+pkgname="lib32-$_basename"
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A thin layer of graphic data types"
+url="https://github.com/ebassi/graphene"
+arch=('x86_64')
+license=(MIT)
+depends=('lib32-glib2')
+makedepends=('git' 'gobject-introspection')
+source=("git+$url#tag=$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd $_basename
+ sed -i '1s/python$/&2/' build/identfilter.py
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_basename
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --disable-gtk-doc \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32
+ make
+}
+
+check() {
+ cd $_basename
+ make check
+}
+
+package() {
+ cd $_basename
+ make DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"/usr
+ rm -r include share
+}