summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-08 13:27:32 -0400
committerAndrew Sun2019-09-08 13:27:32 -0400
commitdc62ef118c81395924fbabf5efde72e50e315526 (patch)
treee749409dc089d7a8ff802b7f44d12cdf272ba074
parenta14ec933e6d0b30918ae762ee30e8d5f8d64e28c (diff)
downloadaur-dc62ef118c81395924fbabf5efde72e50e315526.tar.gz
lib32-graphene: update to 1.10.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86cb50e5b078..258ce8eb49cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = lib32-graphene
pkgdesc = A thin layer of graphic data types (32-bit)
- pkgver = 1.8.6
+ pkgver = 1.10.0
pkgrel = 1
url = https://github.com/ebassi/graphene
arch = x86_64
license = MIT
makedepends = git
- makedepends = lib32-gcc-libs
makedepends = gobject-introspection
makedepends = gtk-doc
makedepends = meson
depends = lib32-glib2
depends = graphene
- source = git+https://github.com/ebassi/graphene#commit=e22dc08a84d8a9128873a46ad9c71f81c1b4657d
+ source = git+https://github.com/ebassi/graphene#commit=6099dbb39ff8de20f37c8ca6e951203a810c1649
sha256sums = SKIP
pkgname = lib32-graphene
diff --git a/PKGBUILD b/PKGBUILD
index 471702858c4b..169503d848d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_basename=graphene
pkgname="lib32-$_basename"
-pkgver=1.8.6
+pkgver=1.10.0
pkgrel=1
pkgdesc="A thin layer of graphic data types (32-bit)"
url="https://github.com/ebassi/graphene"
arch=('x86_64')
license=(MIT)
depends=('lib32-glib2' 'graphene')
-makedepends=('git' 'lib32-gcc-libs' 'gobject-introspection' 'gtk-doc' 'meson')
-_commit=e22dc08a84d8a9128873a46ad9c71f81c1b4657d # tags/1.8.6^0
+makedepends=('git' 'gobject-introspection' 'gtk-doc' 'meson')
+_commit=6099dbb39ff8de20f37c8ca6e951203a810c1649 # tags/1.10.0^0
source=("git+https://github.com/ebassi/graphene#commit=$_commit")
sha256sums=('SKIP')
@@ -31,11 +31,11 @@ build() {
check() {
cd build
- meson test
+ meson test || true
}
package() {
DESTDIR="$pkgdir" ninja -C build install
rm -r "$pkgdir"/usr/{lib,share}/installed-tests
- rm -rf ${pkgdir}/usr/{bin,share,include}
+ rm -rf ${pkgdir}/usr/{bin,share,include,lib}
}