summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-07-27 19:39:14 -0400
committerAndrew Sun2018-07-27 19:39:14 -0400
commitf552245629a943af9c79c18c641680fcab78295f (patch)
tree5bc6310c250218136c0f715465bcdfe62a58bf8c
parent65f0533e01ce0b8c73813d5de55a125f1a5ddb38 (diff)
downloadaur-f552245629a943af9c79c18c641680fcab78295f.tar.gz
lib32-graphene: update to version 1.8.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
2 files changed, 29 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3f99f60a95f..fc9b945610e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = lib32-graphene
pkgdesc = A thin layer of graphic data types (32-bit)
- pkgver = 1.4.0
- pkgrel = 3
+ pkgver = 1.8.2
+ pkgrel = 1
url = https://github.com/ebassi/graphene
arch = x86_64
license = MIT
makedepends = git
+ makedepends = lib32-gcc-libs
makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = meson
depends = lib32-glib2
- source = git+https://github.com/ebassi/graphene#tag=1.4.0
- md5sums = SKIP
+ depends = graphene
+ source = git+https://github.com/ebassi/graphene#commit=f98e3c378414eafae8b75792ded7496b09baaad9
+ sha256sums = SKIP
pkgname = lib32-graphene
diff --git a/PKGBUILD b/PKGBUILD
index 4a1cbc02365f..9787c23a97fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,45 @@
-# Maintainer: orumin <dev@orum.in>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: orumin <dev@orum.in>
_basename=graphene
pkgname="lib32-$_basename"
-pkgver=1.4.0
-pkgrel=3
+pkgver=1.8.2
+pkgrel=1
pkgdesc="A thin layer of graphic data types (32-bit)"
url="https://github.com/ebassi/graphene"
arch=('x86_64')
license=(MIT)
-depends=('lib32-glib2')
-makedepends=('git' 'gobject-introspection')
-source=("git+$url#tag=$pkgver")
-md5sums=('SKIP')
+depends=('lib32-glib2' 'graphene')
+makedepends=('git' 'lib32-gcc-libs' 'gobject-introspection' 'gtk-doc' 'meson')
+_commit=f98e3c378414eafae8b75792ded7496b09baaad9 # tags/1.8.2^0
+source=("git+https://github.com/ebassi/graphene#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_basename
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
cd $_basename
- sed -i '1s/python$/&2/' build/identfilter.py
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $_basename
-
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure --prefix=/usr --disable-gtk-doc \
- --build=i686-pc-linux-gnu --libdir=/usr/lib32 --disable-tests
- make
+ arch-meson $_basename build --libdir='/usr/lib32' -D gtk_doc=true
+ ninja -C build
}
check() {
- cd $_basename
- make check
+ cd build
+ meson test
}
package() {
- cd $_basename
- make DESTDIR="$pkgdir" install
-
- cd "$pkgdir"/usr
- rm -r include share
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -r "$pkgdir"/usr/{lib,share}/installed-tests
+ rm -rf ${pkgdir}/usr/{bin,share,include}
}