summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2020-05-10 15:05:03 -0300
committerRodrigo Bezerra2020-05-10 15:05:03 -0300
commit333a958ed1a59f9d4d37cc6532eb335b53260a9d (patch)
tree31dcbf234c6dae3d12a475d0bf9f4e955b97a3fe
parentf34975c553be860fcad319903a15db2b325b8b1e (diff)
downloadaur-333a958ed1a59f9d4d37cc6532eb335b53260a9d.tar.gz
Fix build with new vulkan-headers package
-rw-r--r--.SRCINFO4
-rw-r--r--0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch46
-rw-r--r--PKGBUILD18
3 files changed, 60 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f3303d4a749..01aa04c67dd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-plugins-bad
pkgdesc = GStreamer open-source multimedia framework bad plugins (32-bit)
pkgver = 1.16.2
- pkgrel = 4
+ pkgrel = 5
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -70,7 +70,9 @@ pkgbase = lib32-gst-plugins-bad
depends = lib32-zvbi
depends = gst-plugins-bad
source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=a6f26408f74a60d02ce6b4f0daee392ce847055f
+ source = 0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
sha256sums = SKIP
+ sha256sums = 0c6c51a371d8f381a2190280913cc41e06c17c25dbb1167043072003b3f0d338
pkgname = lib32-gst-plugins-bad
diff --git a/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch b/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
new file mode 100644
index 000000000000..a4605b1794a2
--- /dev/null
+++ b/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
@@ -0,0 +1,46 @@
+From 29bf8d8528ec694f65c8fae310adac996322cc74 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@ltnglobal.com>
+Date: Sat, 9 May 2020 19:59:46 +0200
+Subject: [PATCH] vulkan: Drop use of VK_RESULT_BEGIN_RANGE
+
+This was removed in Vulkan 1.2.140.
+
+> Shortly after 2020-04-24, we will be removing the automatically
+> generated `VK_*_BEGIN_RANGE`, `VK_*_END_RANGE`, and `VK_*_RANGE_SIZE`
+> tokens from the Vulkan headers. These tokens are currently defined for
+> some enumerated types, but are explicitly not part of the Vulkan API.
+> They existed only to support some Vulkan implementation internals,
+> which no longer require them. We will be accepting comments on this
+> topic in [#1230], but we strongly suggest any external projects using
+> these tokens immediately migrate away from them.
+
+[#1230]: https://github.com/KhronosGroup/Vulkan-Docs/issues/1230
+---
+ ext/vulkan/vkerror.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/ext/vulkan/vkerror.c b/ext/vulkan/vkerror.c
+index 3fec27e4d..c91589d9b 100644
+--- a/ext/vulkan/vkerror.c
++++ b/ext/vulkan/vkerror.c
+@@ -27,7 +27,7 @@
+ #include "vkerror.h"
+
+ /* *INDENT-OFF* */
+-static const struct
++static const struct
+ {
+ VkResult result;
+ const char *str;
+@@ -63,8 +63,6 @@ _vk_result_to_string (VkResult result)
+
+ if (result >= 0)
+ return NULL;
+- if (result < VK_RESULT_BEGIN_RANGE)
+- return "Unknown Error";
+
+ for (i = 0; i < G_N_ELEMENTS (vk_result_string_map); i++) {
+ if (result == vk_result_string_map[i].result)
+--
+2.26.2
+
diff --git a/PKGBUILD b/PKGBUILD
index be883698f88f..f13d78a877f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=gst-plugins-bad
pkgname=lib32-gst-plugins-bad
pkgver=1.16.2
-pkgrel=4
+pkgrel=5
pkgdesc="GStreamer open-source multimedia framework bad plugins (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -22,8 +22,10 @@ depends=(lib32-aom lib32-bluez-libs lib32-celt lib32-chromaprint lib32-curl lib3
makedepends=(git lib32-gtk3 lib32-libtiger lib32-vulkan-validation-layers lv2
meson python vulkan-headers)
_commit=a6f26408f74a60d02ce6b4f0daee392ce847055f # tags/1.16.2^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
+ "0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch")
+sha256sums=('SKIP'
+ '0c6c51a371d8f381a2190280913cc41e06c17c25dbb1167043072003b3f0d338')
pkgver() {
cd $_basename
@@ -36,6 +38,12 @@ prepare() {
# Fix build with lib32-neon 0.31
git cherry-pick -n f10b424418e448211e3427a76fcd046e157ef0b7
+
+ # Fix build with vulkan-headers 1.2.140
+ git apply -3 ../0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
+
+ # Fix build with GCC 10
+ git cherry-pick -n a0cd455dd0e0375c6395fe732173225ea7e18562
}
build() {
@@ -73,7 +81,6 @@ build() {
-D dtls=disabled
ninja -C build
-
}
check() {
@@ -83,8 +90,5 @@ check() {
package() {
DESTDIR="$pkgdir" meson install -C build
- # Fix link error in /usr/lib32/gstreamer-1.0/libgstdvdread.so
- ln -sr "${pkgdir}/usr/lib32/libdvdread.so" "${pkgdir}/usr/lib32/libdvdread.so.7"
-
rm -rf "${pkgdir}"/usr/{bin,include,share}
}