summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2021-04-30 13:51:10 -0300
committerRodrigo Bezerra2021-04-30 13:51:10 -0300
commit640fd771da80ec2bfcfd930804511312d972bf92 (patch)
treed541844d0d3e6cc9a6a6e201f143cbd45cbfb8a1
parentd10f1600e04916ce675b9c7181a9b80d6c5db03f (diff)
downloadaur-640fd771da80ec2bfcfd930804511312d972bf92.tar.gz
Fix build with lib32-openexr 3.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--gst-plugins-bad-openexr3.patch12
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78ed778ce04f..417348ff1f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-plugins-bad
pkgdesc = Multimedia graph framework - bad plugins (32-bit)
pkgver = 1.18.4
- pkgrel = 1
+ pkgrel = 2
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -86,7 +86,9 @@ pkgbase = lib32-gst-plugins-bad
optdepends = lib32-nvidia-utils: nvcodec plugin
options = !emptydirs
source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860
+ source = gst-plugins-bad-openexr3.patch
sha256sums = SKIP
+ sha256sums = 6bf2b72021586efa41b35507beedb939e952cfd612ce50f5f9e704cf1bd1d876
pkgname = lib32-gst-plugins-bad
diff --git a/PKGBUILD b/PKGBUILD
index 8e305c270175..37b2bebb6bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=gst-plugins-bad
pkgname=lib32-gst-plugins-bad
pkgver=1.18.4
-pkgrel=1
+pkgrel=2
pkgdesc="Multimedia graph framework - bad plugins (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -27,8 +27,10 @@ optdepends=('lib32-nvidia-utils: nvcodec plugin')
checkdepends=(xorg-server-xvfb)
options=(!emptydirs)
_commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860 # tags/1.18.4^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
+ gst-plugins-bad-openexr3.patch)
+sha256sums=('SKIP'
+ '6bf2b72021586efa41b35507beedb939e952cfd612ce50f5f9e704cf1bd1d876')
pkgver() {
cd $_basename
@@ -36,6 +38,12 @@ pkgver() {
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd $_basename
+
+ patch -p1 < ../gst-plugins-bad-openexr3.patch # Fix build with OpenEXR 3
+}
+
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
diff --git a/gst-plugins-bad-openexr3.patch b/gst-plugins-bad-openexr3.patch
new file mode 100644
index 000000000000..14d272550a99
--- /dev/null
+++ b/gst-plugins-bad-openexr3.patch
@@ -0,0 +1,12 @@
+diff --git a/ext/openexr/gstopenexrdec.cpp b/ext/openexr/gstopenexrdec.cpp
+index eeb316cb1..32b1d03c3 100644
+--- a/ext/openexr/gstopenexrdec.cpp
++++ b/ext/openexr/gstopenexrdec.cpp
+@@ -29,6 +29,7 @@
+
+ #include <ImfRgbaFile.h>
+ #include <ImfIO.h>
++#include <ImfInt64.h>
+ using namespace Imf;
+ using namespace Imath;
+