summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2021-10-21 15:27:39 -0300
committerRodrigo Bezerra2021-10-21 15:27:39 -0300
commit9c21b8d250c581d42037bd9dd6ba3f53d52139e9 (patch)
tree1657b2c9ee25a313a8777f5c084eb9346628be4c
parent24b7d96cb5cc59306050437d01f66839f2087f11 (diff)
downloadaur-9c21b8d250c581d42037bd9dd6ba3f53d52139e9.tar.gz
Add patch to accept neon 0.32
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 770a56ee60f7..0e52128cc1f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-plugins-bad
pkgdesc = Multimedia graph framework - bad plugins (32-bit)
pkgver = 1.18.4
- pkgrel = 4
+ pkgrel = 5
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -85,6 +85,8 @@ pkgbase = lib32-gst-plugins-bad
optdepends = lib32-nvidia-utils: nvcodec plugin
options = !emptydirs
source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860
+ source = gst-plugins-bad-neon-0.32.patch::https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/2547.patch
sha256sums = SKIP
+ sha256sums = bbd9b8bcc12ad86ddb58bb93df18777675f3a390e80bf60177fefbf034faa22c
pkgname = lib32-gst-plugins-bad
diff --git a/PKGBUILD b/PKGBUILD
index 949e8e7303b4..ae42e3125eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=gst-plugins-bad
pkgname=lib32-gst-plugins-bad
pkgver=1.18.4
-pkgrel=4
+pkgrel=5
pkgdesc="Multimedia graph framework - bad plugins (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -27,8 +27,10 @@ optdepends=('lib32-nvidia-utils: nvcodec plugin')
checkdepends=(xorg-server-xvfb)
options=(!emptydirs)
_commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860 # tags/1.18.4^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
+ gst-plugins-bad-neon-0.32.patch::https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/2547.patch)
+sha256sums=('SKIP'
+ 'bbd9b8bcc12ad86ddb58bb93df18777675f3a390e80bf60177fefbf034faa22c')
pkgver() {
cd $_basename
@@ -41,6 +43,8 @@ prepare() {
git cherry-pick -n 68858358544dd3b7e20663f731db22fd74a78a45 # fix build with GCC 11
git cherry-pick -n a9fafd98b74fd184b178604095d35ac6105119b8 # fix build with OpenEXR 3
+
+ patch -p1 -i ../gst-plugins-bad-neon-0.32.patch # Accept neon 0.32
}
build() {