summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2021-08-02 20:06:54 -0300
committerRodrigo Bezerra2021-08-02 20:06:54 -0300
commitee41d843c2ab149c9fdfd3bde161296ff6843cb9 (patch)
tree1ad2d42665c74d5a7770a908d050933e8181e674
parent640fd771da80ec2bfcfd930804511312d972bf92 (diff)
downloadaur-ee41d843c2ab149c9fdfd3bde161296ff6843cb9.tar.gz
Remove patch and add git cherry-picks
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--gst-plugins-bad-openexr3.patch12
3 files changed, 6 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 417348ff1f48..7e0dddc5b854 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-plugins-bad
pkgdesc = Multimedia graph framework - bad plugins (32-bit)
pkgver = 1.18.4
- pkgrel = 2
+ pkgrel = 3
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -86,9 +86,6 @@ pkgbase = lib32-gst-plugins-bad
optdepends = lib32-nvidia-utils: nvcodec plugin
options = !emptydirs
source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860
- source = gst-plugins-bad-openexr3.patch
sha256sums = SKIP
- sha256sums = 6bf2b72021586efa41b35507beedb939e952cfd612ce50f5f9e704cf1bd1d876
pkgname = lib32-gst-plugins-bad
-
diff --git a/PKGBUILD b/PKGBUILD
index 37b2bebb6bd7..7b511353c27e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=gst-plugins-bad
pkgname=lib32-gst-plugins-bad
pkgver=1.18.4
-pkgrel=2
+pkgrel=3
pkgdesc="Multimedia graph framework - bad plugins (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -27,10 +27,8 @@ optdepends=('lib32-nvidia-utils: nvcodec plugin')
checkdepends=(xorg-server-xvfb)
options=(!emptydirs)
_commit=8cb03bdf01ca6ad8c87f951bcd7962c3ca9f6860 # tags/1.18.4^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
- gst-plugins-bad-openexr3.patch)
-sha256sums=('SKIP'
- '6bf2b72021586efa41b35507beedb939e952cfd612ce50f5f9e704cf1bd1d876')
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd $_basename
@@ -41,7 +39,8 @@ pkgver() {
prepare() {
cd $_basename
- patch -p1 < ../gst-plugins-bad-openexr3.patch # Fix build with OpenEXR 3
+ git cherry-pick -n 68858358544dd3b7e20663f731db22fd74a78a45 # fix build with GCC 11
+ git cherry-pick -n a9fafd98b74fd184b178604095d35ac6105119b8 # fix build with OpenEXR 3
}
build() {
diff --git a/gst-plugins-bad-openexr3.patch b/gst-plugins-bad-openexr3.patch
deleted file mode 100644
index 14d272550a99..000000000000
--- a/gst-plugins-bad-openexr3.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/ext/openexr/gstopenexrdec.cpp b/ext/openexr/gstopenexrdec.cpp
-index eeb316cb1..32b1d03c3 100644
---- a/ext/openexr/gstopenexrdec.cpp
-+++ b/ext/openexr/gstopenexrdec.cpp
-@@ -29,6 +29,7 @@
-
- #include <ImfRgbaFile.h>
- #include <ImfIO.h>
-+#include <ImfInt64.h>
- using namespace Imf;
- using namespace Imath;
-