summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-11-25 21:37:22 -0300
committerRodrigo Bezerra2019-11-25 21:37:22 -0300
commitbec9b386c27b4940d5b690120ae0a275afe41a96 (patch)
tree4f1a955f1bd7d363534e76ccb38a51cacfb04295
parentd362d3df2d9e86850b5d6f6b4cdb272cf36a8d29 (diff)
downloadaur-bec9b386c27b4940d5b690120ae0a275afe41a96.tar.gz
Update to version 1.16.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD101
2 files changed, 48 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 355e2c67bbfe..dde756964283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = lib32-gst-plugins-ugly
- pkgdesc = GStreamer Multimedia Framework Ugly Plugins (32-bit)
- pkgver = 1.14.4
- pkgrel = 2
+ pkgdesc = GStreamer open-source multimedia framework ugly plugins (32-bit)
+ pkgver = 1.16.1
+ pkgrel = 1
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
- makedepends = python
- makedepends = lib32-x264
- makedepends = autoconf-archive
makedepends = git
- makedepends = valgrind-multilib
+ makedepends = meson
+ makedepends = python
depends = lib32-gst-plugins-base-libs
depends = lib32-libdvdread
depends = lib32-libmpeg2
@@ -19,8 +17,8 @@ pkgbase = lib32-gst-plugins-ugly
depends = lib32-x264
depends = lib32-opencore-amr
depends = gst-plugins-ugly
- source = git+https://github.com/freedesktop/gstreamer-gst-plugins-ugly.git#commit=e1bf2aa184f83ff9fd5b7850c460129100ac6d1a
- source = gst-common::git+https://github.com/freedesktop/gstreamer-common.git
+ source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git#commit=34c7d2b37b1ef73206e282e15d6382fae2182137
+ source = gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f5cf7e9780c1..4b2a1d2f8a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,79 +1,60 @@
-# Maintainer: orumin <dev@orum.in>
-# Maintainer: Adam <adam900710@gmail.com>
+# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+# Contributor: orumin <dev@orum.in>
+# Contributor: Adam <adam900710@gmail.com>
_basename=gst-plugins-ugly
-pkgname="lib32-$_basename"
-pkgver=1.14.4
-pkgrel=2
-pkgdesc="GStreamer Multimedia Framework Ugly Plugins (32-bit)"
-arch=('x86_64')
-license=('LGPL')
+pkgname=lib32-gst-plugins-ugly
+pkgver=1.16.1
+pkgrel=1
+pkgdesc="GStreamer open-source multimedia framework ugly plugins (32-bit)"
url="https://gstreamer.freedesktop.org/"
-depends=('lib32-gst-plugins-base-libs' 'lib32-libdvdread'
- 'lib32-libmpeg2' 'lib32-a52dec' 'lib32-libsidplay'
- 'lib32-libcdio' 'lib32-x264' 'lib32-opencore-amr' 'gst-plugins-ugly')
-makedepends=('python' 'lib32-x264' 'autoconf-archive' 'git' 'valgrind-multilib')
-_commit=e1bf2aa184f83ff9fd5b7850c460129100ac6d1a # tags/1.14.4^0
-
-#source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=$_commit"
-# "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
-# I'm not sure if I'm just unlucky or whatever, the git server from freedesktop is too slow
-# So switch to github mirrors
-source=("git+https://github.com/freedesktop/gstreamer-gst-plugins-ugly.git#commit=$_commit"
- "gst-common::git+https://github.com/freedesktop/gstreamer-common.git")
-
+arch=(x86_64)
+license=(LGPL)
+depends=(lib32-gst-plugins-base-libs lib32-libdvdread lib32-libmpeg2 lib32-a52dec lib32-libsidplay
+ lib32-libcdio lib32-x264 lib32-opencore-amr gst-plugins-ugly)
+makedepends=(git meson python)
+_commit=34c7d2b37b1ef73206e282e15d6382fae2182137 # tags/1.16.1^0
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git#commit=$_commit"
+ "gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git")
sha256sums=('SKIP'
'SKIP')
+
pkgver() {
- cd $_basename
- git describe --tags | sed 's/-/+/g'
+ cd $_basename
+
+ git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd $_basename
-
- git submodule init
- git config --local submodule.common.url "$srcdir/gst-common"
- git submodule update
+ cd $_basename
- NOCONFIGURE=1 ./autogen.sh
+ git submodule init
+ git config --local submodule.common.url "$srcdir/gst-common"
+ git submodule update
}
build() {
- cd $_basename
-
- export CC='gcc -m32'
- export CXX='g++ -m32'
- export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib32 \
- --libdir=/usr/lib32 \
- --build=i686-pc-linux-gnu \
- --with-package-name="GStreamer Ugly Plugins (Arch Linux)" \
- --with-package-origin="http://www.archlinux.org/" \
- --with-x264-libraries="/usr/lib32/libx264.so" \
- --enable-experimental \
- --disable-gtk-doc \
- --disable-static
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
+
+ arch-meson $_basename build \
+ --libdir=/usr/lib32 \
+ -D gobject-cast-checks=disabled \
+ -D glib-asserts=disabled \
+ -D glib-checks=disabled \
+ -D package-name="GStreamer Ugly Plugins (Arch Linux)" \
+ -D package-origin="https://www.archlinux.org/"
+
+ ninja -C build
}
-#check() {
-# cd $_basename
-# make check
-#}
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- cd $_basename
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" meson install -C build
- rm -r "$pkgdir"/usr/share
+ rm -rf "${pkgdir}/usr/share"
}