summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam2019-06-08 21:39:58 +0800
committerAdam2019-06-08 21:39:58 +0800
commitd362d3df2d9e86850b5d6f6b4cdb272cf36a8d29 (patch)
tree7da32ec0888108143719349909078579648ac56f
parent0156a74d4e516b933ca57a198d96bfbf17e56e47 (diff)
downloadaur-d362d3df2d9e86850b5d6f6b4cdb272cf36a8d29.tar.gz
Use github mirrors to get rid of the slow official git repo, and skip
selftest Signed-off-by: Adam <adam900710@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89c3e0df87b5..355e2c67bbfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-plugins-ugly
pkgdesc = GStreamer Multimedia Framework Ugly Plugins (32-bit)
pkgver = 1.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -19,8 +19,8 @@ pkgbase = lib32-gst-plugins-ugly
depends = lib32-x264
depends = lib32-opencore-amr
depends = gst-plugins-ugly
- source = git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=e1bf2aa184f83ff9fd5b7850c460129100ac6d1a
- source = gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common
+ source = git+https://github.com/freedesktop/gstreamer-gst-plugins-ugly.git#commit=e1bf2aa184f83ff9fd5b7850c460129100ac6d1a
+ source = gst-common::git+https://github.com/freedesktop/gstreamer-common.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f7da520714bb..f5cf7e9780c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=gst-plugins-ugly
pkgname="lib32-$_basename"
pkgver=1.14.4
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (32-bit)"
arch=('x86_64')
license=('LGPL')
@@ -14,8 +14,14 @@ depends=('lib32-gst-plugins-base-libs' 'lib32-libdvdread'
'lib32-libcdio' 'lib32-x264' 'lib32-opencore-amr' 'gst-plugins-ugly')
makedepends=('python' 'lib32-x264' 'autoconf-archive' 'git' 'valgrind-multilib')
_commit=e1bf2aa184f83ff9fd5b7850c460129100ac6d1a # tags/1.14.4^0
-source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=$_commit"
- "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+
+#source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=$_commit"
+# "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+# I'm not sure if I'm just unlucky or whatever, the git server from freedesktop is too slow
+# So switch to github mirrors
+source=("git+https://github.com/freedesktop/gstreamer-gst-plugins-ugly.git#commit=$_commit"
+ "gst-common::git+https://github.com/freedesktop/gstreamer-common.git")
+
sha256sums=('SKIP'
'SKIP')
pkgver() {
@@ -60,10 +66,10 @@ build() {
make
}
-check() {
- cd $_basename
- make check
-}
+#check() {
+# cd $_basename
+# make check
+#}
package() {
cd $_basename