summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-06-28 15:44:30 +0300
committerGordonGR2015-06-28 15:44:30 +0300
commit5067205f3e107de6c9fe299b3520e82e985e9613 (patch)
tree9d108d1e28c09c7bd409cb955ceb88da146be4f6
parente5e2ed3221b0e03b1017789eb8534be8f01c30de (diff)
downloadaur-5067205f3e107de6c9fe299b3520e82e985e9613.tar.gz
On par with gstreamer0.10-bad 0.10.23-10 from [extra]
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
-rw-r--r--disable-assrender-test.patch11
-rw-r--r--disable-camerabin-test.patch10
-rw-r--r--drop-vpx-compat-defs.patch26
-rw-r--r--faad2-version-check.patch35
-rw-r--r--fix-libmodplug-include.patch12
7 files changed, 137 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d09b2db4dbc7..825da7c0c548 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gstreamer0.10-bad
pkgdesc = GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad) (32 bit)
pkgver = 0.10.23
- pkgrel = 6
+ pkgrel = 7
url = http://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -36,8 +36,18 @@ pkgbase = lib32-gstreamer0.10-bad
depends = gstreamer0.10-bad
options = !libtool
options = !emptydirs
- source = http://gstreamer.freedesktop.org//src/gst-plugins-bad/gst-plugins-bad-0.10.23.tar.xz
- md5sums = e4822fa2cc933768e2998311a1565979
+ source = git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125
+ source = fix-libmodplug-include.patch
+ source = drop-vpx-compat-defs.patch
+ source = disable-assrender-test.patch
+ source = disable-camerabin-test.patch
+ source = faad2-version-check.patch
+ md5sums = SKIP
+ md5sums = 447c12a784b13aac9e47e48741d26a67
+ md5sums = 476a02484af2e9bdc1cb4a703b531cec
+ md5sums = 025438e630b571bfa90171e36d4240e5
+ md5sums = 2e17f524b0db1469cfa36703bf459153
+ md5sums = dfa7e5723542d0fabebf509cb321535b
pkgname = lib32-gstreamer0.10-bad
pkgdesc = GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad, lib32)
diff --git a/PKGBUILD b/PKGBUILD
index ecef365b2673..9dbb525e07ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgbase=gstreamer0.10-bad
pkgbase=lib32-$_pkgbase
pkgname=('lib32-gstreamer0.10-bad' 'lib32-gstreamer0.10-bad-plugins')
pkgver=0.10.23
-pkgrel=6
+pkgrel=7
arch=('x86_64')
license=('LGPL' 'GPL')
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad) (32 bit)"
@@ -14,17 +14,39 @@ makedepends=('gcc-multilib' 'lib32-libvdpau' 'lib32-libass' 'lib32-libcdaudio' '
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
-source=($url/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz)
-md5sums=('e4822fa2cc933768e2998311a1565979')
+source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
+fix-libmodplug-include.patch
+drop-vpx-compat-defs.patch
+disable-assrender-test.patch
+disable-camerabin-test.patch
+faad2-version-check.patch)
+
+md5sums=('SKIP'
+ '447c12a784b13aac9e47e48741d26a67'
+ '476a02484af2e9bdc1cb4a703b531cec'
+ '025438e630b571bfa90171e36d4240e5'
+ '2e17f524b0db1469cfa36703bf459153'
+ 'dfa7e5723542d0fabebf509cb321535b')
+
+prepare() {
+cd gst-plugins-bad
+sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
+patch -Np1 -i ../fix-libmodplug-include.patch
+patch -Np1 -i ../drop-vpx-compat-defs.patch
+patch -Np1 -i ../disable-assrender-test.patch
+patch -Np1 -i ../disable-camerabin-test.patch
+patch -Np1 -i ../faad2-version-check.patch
+}
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
-cd gst-plugins-bad-$pkgver
+
+cd gst-plugins-bad
+NOCONFIGURE=1 ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental \
+ --disable-static --enable-experimental --disable-gtk-doc \
--with-package-name="GStreamer Bad Plugins (Archlinux)" \
--with-package-origin="http://www.archlinux.org/" \
--libdir=/usr/lib32 \
@@ -39,7 +61,7 @@ package_lib32-gstreamer0.10-bad() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad, lib32)"
depends=('lib32-gstreamer0.10-base')
-cd gst-plugins-bad-$pkgver
+cd gst-plugins-bad
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir/usr"/{include,share}
}
@@ -50,7 +72,7 @@ depends=("lib32-gstreamer0.10-bad=${pkgver}" 'lib32-libdca' 'bzip2' 'lib32-libdc
install=lib32-gstreamer0.10-bad-plugins.install
-cd gst-plugins-bad-$pkgver
+cd gst-plugins-bad
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C sys DESTDIR="${pkgdir}" install
diff --git a/disable-assrender-test.patch b/disable-assrender-test.patch
new file mode 100644
index 000000000000..07ce4f1bb10a
--- /dev/null
+++ b/disable-assrender-test.patch
@@ -0,0 +1,11 @@
+--- a/tests/check/elements/assrender.c
++++ b/tests/check/elements/assrender.c
+@@ -289,8 +289,6 @@ assrender_suite (void)
+ tcase_set_timeout (tc_chain, 120);
+
+ suite_add_tcase (s, tc_chain);
+- tcase_add_test (tc_chain, test_assrender_basic_xRGB);
+- tcase_add_test (tc_chain, test_assrender_basic_I420);
+
+ return s;
+ }
diff --git a/disable-camerabin-test.patch b/disable-camerabin-test.patch
new file mode 100644
index 000000000000..964351ae6b2e
--- /dev/null
+++ b/disable-camerabin-test.patch
@@ -0,0 +1,10 @@
+--- gst-plugins-bad/tests/check/Makefile.am.orig 2013-12-10 22:01:50.504567189 +0000
++++ gst-plugins-bad/tests/check/Makefile.am 2013-12-10 22:02:17.081058500 +0000
+@@ -181,7 +181,6 @@
+ elements/autovideoconvert \
+ elements/asfmux \
+ elements/baseaudiovisualizer \
+- elements/camerabin \
+ elements/camerabin2 \
+ elements/dataurisrc \
+ elements/legacyresample \
diff --git a/drop-vpx-compat-defs.patch b/drop-vpx-compat-defs.patch
new file mode 100644
index 000000000000..c7bec44e0577
--- /dev/null
+++ b/drop-vpx-compat-defs.patch
@@ -0,0 +1,26 @@
+--- gst-plugins-bad.orig/ext/vp8/gstvp8utils.h 2015-04-21 03:31:33.134952881 +0300
++++ gst-plugins-bad/ext/vp8/gstvp8utils.h 2015-04-21 03:32:45.553520671 +0300
+@@ -25,23 +25,6 @@
+
+ G_BEGIN_DECLS
+
+-/* Some compatibility defines for older libvpx versions */
+-#ifndef VPX_IMG_FMT_I420
+-#define VPX_IMG_FMT_I420 IMG_FMT_I420
+-#endif
+-
+-#ifndef VPX_PLANE_Y
+-#define VPX_PLANE_Y PLANE_Y
+-#endif
+-
+-#ifndef VPX_PLANE_U
+-#define VPX_PLANE_U PLANE_U
+-#endif
+-
+-#ifndef VPX_PLANE_V
+-#define VPX_PLANE_V PLANE_V
+-#endif
+-
+ const char * gst_vpx_error_name (vpx_codec_err_t status);
+
+ G_END_DECLS
diff --git a/faad2-version-check.patch b/faad2-version-check.patch
new file mode 100644
index 000000000000..aad0fb4b0439
--- /dev/null
+++ b/faad2-version-check.patch
@@ -0,0 +1,35 @@
+From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Wed, 13 May 2015 16:23:26 +0200
+Subject: fix faad2 version check
+
+On fedora 22, the output of cpp inserts extra debug comments, which
+makes our regexp for the faad2 version check fail. This in turn causes
+it to compile with the wrong arguments passed which then causes stack
+corruption and crashes.
+
+Fix this by only checking for the version (which should be by itself on
+a single line). This is potentially less safe, it might be possible that
+a similar string would appear in a later version in the header file.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
+
+diff --git a/configure.ac b/configure.ac
+index f5ce28c..d295253 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
+ AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
+ for minor in 10 9 8 7 6 5 0; do
+ if test x$faad2_minor_version = "x"; then
+- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
++ AC_EGREP_CPP([\"2\.$minor\"$], [
+ #include <$faad_hdr>
+- GST_CHECK_FAAD_VERSION FAAD2_VERSION
++ FAAD2_VERSION
+ ], [
+ faad2_minor_version=$minor
+ ])
+--
+cgit v0.10.2
+
diff --git a/fix-libmodplug-include.patch b/fix-libmodplug-include.patch
new file mode 100644
index 000000000000..6dc6bf1772c1
--- /dev/null
+++ b/fix-libmodplug-include.patch
@@ -0,0 +1,12 @@
+diff -uprw gst-plugins-bad.orig/ext/modplug/gstmodplug.cc gst-plugins-bad/ext/modplug/gstmodplug.cc
+--- gst-plugins-bad.orig/ext/modplug/gstmodplug.cc 2015-04-21 03:15:25.929456272 +0300
++++ gst-plugins-bad/ext/modplug/gstmodplug.cc 2015-04-21 03:18:54.624976723 +0300
+@@ -50,7 +50,7 @@
+ #define WORDS_BIGENDIAN 0
+ #endif
+
+-#include <stdafx.h>
++#include <libmodplug/stdafx.h>
+ #include <libmodplug/sndfile.h>
+
+ #include "gstmodplug.h"