summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-06-24 13:43:54 +0300
committerGordonGR2015-06-24 13:43:54 +0300
commit4daca5c427ae2594bcdb56392809092e7568fb30 (patch)
tree531f2738111718faf4f9dae10098e8350abd84dd
parentd54f7eff92ca4745f80733093896203d1162b798 (diff)
downloadaur-4daca5c427ae2594bcdb56392809092e7568fb30.tar.gz
Update on par with gstreamer0.10-good 0.10.31-8 in [extra]
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--souptest.patch28
3 files changed, 42 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1c440c0fd31..5d5b8f80b683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-gstreamer0.10-good
pkgver = 0.10.31
- pkgrel = 4
+ pkgrel = 5
url = http://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -24,14 +24,17 @@ pkgbase = lib32-gstreamer0.10-good
makedepends = lib32-jack
makedepends = git
makedepends = lib32-cairo
+ makedepends = lib32-libgudev
depends = gstreamer0.10-good
depends = gstreamer0.10-good-plugins
depends = lib32-gstreamer0.10-base
options = !emptydirs
source = git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-good#commit=e28fd8886f05bb51c147f871f3a1db2fc2b735a9
source = test-rtp-payloading.patch
+ source = souptest.patch
md5sums = SKIP
md5sums = 6781763eb752d57f3d111a41905d25bd
+ md5sums = 271035db9b124f4f95731803b52bae27
pkgname = lib32-gstreamer0.10-good
pkgdesc = GStreamer Multimedia Framework Good plugin libraries (lib32)
diff --git a/PKGBUILD b/PKGBUILD
index 5f6397784dca..0a59a4396c3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,26 @@ _pkgbase=gstreamer0.10-good
pkgname=('lib32-gstreamer0.10-good' 'lib32-gstreamer0.10-good-plugins')
_pkgname=('gstreamer0.10-good' 'gstreamer0.10-good-plugins')
pkgver=0.10.31
-pkgrel=4
+pkgrel=5
arch=('x86_64')
license=('LGPL')
depends=('gstreamer0.10-good' 'gstreamer0.10-good-plugins' "lib32-gstreamer0.10-base")
-makedepends=('intltool' 'pkgconfig' 'libavc1394' 'libiec61883' 'aalib' 'lib32-libshout' 'lib32-libdv' 'lib32-flac' 'lib32-gconf' 'lib32-wavpack' 'lib32-taglib' 'lib32-libsoup' 'lib32-v4l-utils' 'lib32-libcaca' 'lib32-bzip2' 'lib32-gdk-pixbuf2' 'lib32-libpulse' 'lib32-jack' 'git' 'lib32-cairo')
+makedepends=('intltool' 'pkgconfig' 'libavc1394' 'libiec61883' 'aalib' 'lib32-libshout' 'lib32-libdv' 'lib32-flac' 'lib32-gconf' 'lib32-wavpack' 'lib32-taglib' 'lib32-libsoup' 'lib32-v4l-utils' 'lib32-libcaca' 'lib32-bzip2' 'lib32-gdk-pixbuf2' 'lib32-libpulse' 'lib32-jack' 'git' 'lib32-cairo' 'lib32-libgudev')
url="http://gstreamer.freedesktop.org/"
options=(!emptydirs)
source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-good#commit=e28fd8886f05bb51c147f871f3a1db2fc2b735a9"
- "test-rtp-payloading.patch")
+ "test-rtp-payloading.patch"
+ "souptest.patch")
md5sums=('SKIP'
- '6781763eb752d57f3d111a41905d25bd')
-
+ '6781763eb752d57f3d111a41905d25bd'
+ '271035db9b124f4f95731803b52bae27')
+
prepare() {
cd gst-plugins-good
sed -i '/AC_PATH_XTRA/d' configure.ac
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
-patch -p1 -i ../test-rtp-payloading.patch
+patch -Np1 -i ../test-rtp-payloading.patch
+patch -Np1 -i ../souptest.patch
}
build() {
@@ -40,6 +43,7 @@ NOCONFIGURE=1 ./autogen.sh
--disable-esd \
--disable-gtk-doc \
--libdir=/usr/lib32/ \
+ --libexecdir=/usr/lib32 \
--build=i686-unknown-linux-gnu \
--with-package-name="GStreamer Good Plugins (Archlinux)" \
--with-package-origin="http://www.archlinux.org/"
diff --git a/souptest.patch b/souptest.patch
new file mode 100644
index 000000000000..a025eb6b9834
--- /dev/null
+++ b/souptest.patch
@@ -0,0 +1,28 @@
+From 5765db50a19498e3d1576b4279cb2ca984da9dcd Mon Sep 17 00:00:00 2001
+From: Edward Hervey <bilboed@bilboed.com>
+Date: Tue, 23 Sep 2014 09:47:31 +0200
+Subject: check/soup: Temporarily disable G_ENABLE_DIAGNOSTIC
+
+The SOUP_SERVER_PORT property has been deprecated in recent libsoup
+versions.
+
+diff --git a/tests/check/elements/souphttpsrc.c b/tests/check/elements/souphttpsrc.c
+index 33431ac..dfb682b 100644
+--- a/tests/check/elements/souphttpsrc.c
++++ b/tests/check/elements/souphttpsrc.c
+@@ -602,7 +602,12 @@ run_server (guint * http_port, guint * https_port)
+
+ *http_port = *https_port = 0;
+
++ /* The G_ENABLE_DIAGNOSTIC is temporarily overriden to avoid
++ * property deprecation warnings (for the SOUP_SERVER_PORT
++ * property) */
++ g_setenv ("G_ENABLE_DIAGNOSTIC", "0", TRUE);
+ server = soup_server_new (SOUP_SERVER_PORT, port, NULL);
++ g_setenv ("G_ENABLE_DIAGNOSTIC", "1", TRUE);
+ if (!server) {
+ GST_DEBUG ("Unable to bind to server port %u", port);
+ return FALSE;
+--
+cgit v0.10.2
+