summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-04-10 03:50:59 +0900
committerasukaminato2023-04-10 03:50:59 +0900
commita2b0cb90b64486e9be5a29956cc20daf348ee9e9 (patch)
tree0a92dbed72fb9b28dcc00a81b2cf2869beba06a1
parent0160ed4278fc83a8dc787fdcc5eb49d91f234764 (diff)
downloadaur-a2b0cb90b64486e9be5a29956cc20daf348ee9e9.tar.gz
1.13.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rwxr-xr-xPKGBUILD14
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beb870ec414e..6ffefe3bd6de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-gtest
pkgdesc = Google Test - C++ testing utility based on the xUnit framework (like JUnit)
- pkgver = 1.10.0
+ pkgver = 1.13.0
pkgrel = 1
url = https://github.com/google/googletest
arch = x86_64
@@ -11,8 +11,7 @@ pkgbase = lib32-gtest
options = !buildflags
options = staticlibs
options = !strip
- source = https://github.com/google/googletest/archive/release-1.10.0.tar.gz
- sha512sums = bd52abe938c3722adc2347afad52ea3a17ecc76730d8d16b065e165bc7477d762bce0997a427131866a89f1001e3f3315198204ffa5d643a9355f1f4d0d7b1a9
+ source = https://github.com/google/googletest/archive/refs/tags/v1.13.0.tar.gz
+ sha512sums = 70c0cfb1b4147bdecb467ecb22ae5b5529eec0abc085763213a796b7cdbd81d1761d12b342060539b936fa54f345d33f060601544874d6213fdde79111fa813e
pkgname = lib32-gtest
-
diff --git a/.gitignore b/.gitignore
index 0cd1c4c079c3..497ba14db6fd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@ src/
pkg/
*.tar.gz
*.pkg.tar.xz
+*.zst
+
diff --git a/PKGBUILD b/PKGBUILD
index dc4642e663e4..5d953b50b20d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: darkprof <darkprof83@gmail.com>
-
+# Contributor: darkprof <darkprof83@gmail.com>
+# Contributor: asuka minato
_pkgname=gtest
pkgname=lib32-${_pkgname}
-pkgver=1.10.0
+pkgver=1.13.0
pkgrel=1
pkgdesc="Google Test - C++ testing utility based on the xUnit framework (like JUnit)"
arch=('x86_64')
@@ -11,11 +11,11 @@ license=(custom:BSD3)
depends=("${_pkgname}" 'lib32-gcc-libs')
makedepends=('cmake')
options=(!buildflags staticlibs !strip)
-source=("https://github.com/google/googletest/archive/release-${pkgver}.tar.gz")
-sha512sums=('bd52abe938c3722adc2347afad52ea3a17ecc76730d8d16b065e165bc7477d762bce0997a427131866a89f1001e3f3315198204ffa5d643a9355f1f4d0d7b1a9')
+source=("https://github.com/google/googletest/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('70c0cfb1b4147bdecb467ecb22ae5b5529eec0abc085763213a796b7cdbd81d1761d12b342060539b936fa54f345d33f060601544874d6213fdde79111fa813e')
build() {
- cd "googletest-release-${pkgver}"
+ cd "googletest-${pkgver}"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_SHARED_LIBS=ON \
@@ -29,7 +29,7 @@ build() {
}
package() {
- cd "googletest-release-${pkgver}"
+ cd "googletest-${pkgver}"
mkdir -pm 0755 "${pkgdir}/usr/lib32"
install -m 644 lib/libgmock{,_main}.so "${pkgdir}"/usr/lib32