summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-26 16:07:59 +0800
committermaz-12015-10-26 16:07:59 +0800
commitf3e6fd347b44d1a53c9779c6aa6244e9c0f7fd14 (patch)
tree1cd362032ebd018dfba1b3e67b24a0978ae8bf6c
downloadaur-f3e6fd347b44d1a53c9779c6aa6244e9c0f7fd14.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef95ded2f13e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-gtk-engine-equinox
+ pkgdesc = A heavily modified version of the beautiful Aurora engine
+ pkgver = 1.50
+ pkgrel = 2
+ url = http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libtool
+ depends = lib32-gtk2
+ depends = gtk-engine-equinox
+ options = !libtool
+ source = http://gnome-look.org/CONTENT/content-files/121881-equinox-1.50.tar.gz
+ sha256sums = 0cf8b8cc841e0da7d4a08ab5a70d3bb330fd76bdcb03165a47aaddcd47e02227
+
+pkgname = lib32-gtk-engine-equinox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92c8d9f69b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer : SpepS <dreamspepser at yahoo dot it>
+# Contributor: Frikilinux <frikilinux at frikilinux.com.ar>
+
+pkgname=lib32-gtk-engine-equinox
+pkgver=1.50
+pkgrel=2
+pkgdesc="A heavily modified version of the beautiful Aurora engine"
+url="http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('lib32-gtk2' 'gtk-engine-equinox')
+makedepends=('libtool')
+options=('!libtool')
+source=("http://gnome-look.org/CONTENT/content-files/121881-equinox-$pkgver.tar.gz")
+sha256sums=('0cf8b8cc841e0da7d4a08ab5a70d3bb330fd76bdcb03165a47aaddcd47e02227')
+
+build() {
+ cd "$srcdir/equinox-$pkgver"
+ # toolbar fix
+ sed -i "s/=\( EQUINOX_IS_TOOLBAR\)/= widget \&\&\1/" \
+ src/equinox_style.c
+
+ # glib2 fix
+ sed -i "/gtimer/d" src/animation.c
+
+ export CC='gcc -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib32
+ --enable-animation
+ make
+}
+package() {
+ cd "$srcdir/equinox-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}