summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-03-18 22:18:23 -0300
committerRodrigo Bezerra2019-03-18 22:18:23 -0300
commit1cef60e530514f7b01bbc322246b30ed994e431d (patch)
tree433f58da5898dd2786afbba3a35a51ff89be1f26
parent654e442fd6061535f5125f7d92178cd955be4645 (diff)
downloadaur-1cef60e530514f7b01bbc322246b30ed994e431d.tar.gz
Update to version 1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
2 files changed, 13 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d11b246e13ed..006fafbe6e8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = lib32-gupnp
pkgdesc = An object-oriented UPNP framework (32-bit)
- pkgver = 1.0.3
+ pkgver = 1.2.0
pkgrel = 1
url = https://wiki.gnome.org/Projects/GUPnP
arch = x86_64
license = LGPL
- makedepends = autoconf-archive
makedepends = git
makedepends = gobject-introspection
+ makedepends = meson
makedepends = vala
depends = lib32-gssdp
depends = gupnp
- source = git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=0e4f31cfc489a2c21f052885695902ae5ba98c8a
+ source = git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=386c5332d4daa758ffbc36462f0aca3e7f18f60c
sha256sums = SKIP
pkgname = lib32-gupnp
diff --git a/PKGBUILD b/PKGBUILD
index 1900d873516c..cc0ac536434f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_basename=gupnp
pkgname=lib32-gupnp
-pkgver=1.0.3
+pkgver=1.2.0
pkgrel=1
pkgdesc="An object-oriented UPNP framework (32-bit)"
arch=(x86_64)
url="https://wiki.gnome.org/Projects/GUPnP"
license=(LGPL)
depends=(lib32-gssdp gupnp)
-makedepends=(autoconf-archive git gobject-introspection vala)
-_commit=0e4f31cfc489a2c21f052885695902ae5ba98c8a # tags/gupnp-1.0.3^0
+makedepends=(git gobject-introspection meson vala)
+_commit=386c5332d4daa758ffbc36462f0aca3e7f18f60c # tags/gupnp-1.2.0^0
source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
sha256sums=('SKIP')
@@ -20,46 +20,24 @@ pkgver() {
git describe --tags | sed 's/^gupnp-//;s/-/+/g'
}
-prepare() {
- cd $_basename
-
- NOCONFIGURE=1 ./autogen.sh
-}
-
build() {
- cd $_basename
-
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure \
- --build=i686-pc-linux-gnu \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libdir=/usr/lib32 \
- --with-context-manager=linux \
- --enable-compile-warnings=minimum \
- --disable-debug \
- --disable-static \
- --disable-gtk-doc
+ arch-meson $_basename build \
+ --libdir='/usr/lib32' \
+ -Dgtk_doc=false
- make
+ ninja -C build
}
check() {
- cd $_basename
-
- make check
+ meson test -C build
}
package() {
- cd $_basename
-
- make DESTDIR="$pkgdir" install
-
- cd "$pkgdir/usr"
+ DESTDIR="$pkgdir" meson install -C build
- rm -r bin include share
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
}