summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-01-22 20:47:37 -0300
committerRodrigo Bezerra2019-01-22 20:47:37 -0300
commit654e442fd6061535f5125f7d92178cd955be4645 (patch)
treededaea59578c321fd070c540e9381f502541e744
downloadaur-654e442fd6061535f5125f7d92178cd955be4645.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD65
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d11b246e13ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-gupnp
+ pkgdesc = An object-oriented UPNP framework (32-bit)
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/GUPnP
+ arch = x86_64
+ license = LGPL
+ makedepends = autoconf-archive
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = lib32-gssdp
+ depends = gupnp
+ source = git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=0e4f31cfc489a2c21f052885695902ae5ba98c8a
+ sha256sums = SKIP
+
+pkgname = lib32-gupnp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1900d873516c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+
+_basename=gupnp
+pkgname=lib32-gupnp
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="An object-oriented UPNP framework (32-bit)"
+arch=(x86_64)
+url="https://wiki.gnome.org/Projects/GUPnP"
+license=(LGPL)
+depends=(lib32-gssdp gupnp)
+makedepends=(autoconf-archive git gobject-introspection vala)
+_commit=0e4f31cfc489a2c21f052885695902ae5ba98c8a # tags/gupnp-1.0.3^0
+source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_basename
+
+ git describe --tags | sed 's/^gupnp-//;s/-/+/g'
+}
+
+prepare() {
+ cd $_basename
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_basename
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --build=i686-pc-linux-gnu \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib32 \
+ --with-context-manager=linux \
+ --enable-compile-warnings=minimum \
+ --disable-debug \
+ --disable-static \
+ --disable-gtk-doc
+
+ make
+}
+
+check() {
+ cd $_basename
+
+ make check
+}
+
+package() {
+ cd $_basename
+
+ make DESTDIR="$pkgdir" install
+
+ cd "$pkgdir/usr"
+
+ rm -r bin include share
+}