summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2018-11-16 00:32:22 -0500
committerVincent Grande2018-11-16 00:32:22 -0500
commit1089c17e985e1bfcf7f4dafed85f8bab28265df4 (patch)
treecb3fd14f6c4b564f16cb180e4cbd84fd13965abb
downloadaur-1089c17e985e1bfcf7f4dafed85f8bab28265df4.tar.gz
matched official repo PKGBUILD
-rw-r--r--.SRCINFO33
-rwxr-xr-xPKGBUILD79
2 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f0aa98859d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = lib32-harfbuzz-git
+ pkgdesc = OpenType text shaping engine (32-bit)
+ pkgver = 2.1.1+174+g6c22f3fd
+ pkgrel = 1
+ url = http://www.freedesktop.org/wiki/Software/HarfBuzz
+ arch = x86_64
+ license = MIT
+ checkdepends = python-fonttools
+ checkdepends = python-setuptools
+ makedepends = lib32-cairo
+ makedepends = lib32-icu
+ makedepends = gcc-multilib
+ makedepends = ragel
+ makedepends = git
+ makedepends = python
+ depends = lib32-glib2
+ depends = lib32-freetype2
+ depends = harfbuzz
+ source = git+https://anongit.freedesktop.org/git/harfbuzz
+ sha256sums = SKIP
+
+pkgname = lib32-harfbuzz-git
+ provides = lib32-harfbuzz
+ conflicts = lib32-harfbuzz
+
+pkgname = lib32-harfbuzz-icu-git
+ pkgdesc = OpenType text shaping engine (32-bit, ICU integration)
+ depends = lib32-harfbuzz
+ depends = lib32-icu
+ depends = harfbuzz-icu
+ provides = lib32-harfbuzz-icu
+ conflicts = lib32-harfbuzz-icu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..b76c63b8fd67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Florian Pritz <bluewind@xinu.at>
+
+pkgname=(lib32-harfbuzz-git lib32-harfbuzz-icu-git)
+pkgver=2.1.1+174+g6c22f3fd
+pkgrel=1
+pkgdesc="OpenType text shaping engine (32-bit)"
+url="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+arch=(x86_64)
+license=(MIT)
+depends=(lib32-glib2 lib32-freetype2 harfbuzz)
+makedepends=(lib32-cairo lib32-icu gcc-multilib ragel git python)
+checkdepends=(python-fonttools python-setuptools)
+source=("git+https://anongit.freedesktop.org/git/harfbuzz")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd harfbuzz
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd harfbuzz
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd harfbuzz
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --with-cairo \
+ --with-freetype \
+ --with-glib \
+ --with-gobject \
+ --without-graphite2 \
+ --with-icu \
+ --disable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+#check() {
+# cd harfbuzz
+# make check
+#}
+
+package_lib32-harfbuzz-git() {
+
+ provides=('lib32-harfbuzz')
+ conflicts=('lib32-harfbuzz')
+
+ cd harfbuzz
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "${pkgdir}"/usr/{include,share,bin}
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s harfbuzz "$pkgdir/usr/share/licenses/lib32-harfbuzz"
+
+# Split harfbuzz-icu
+ mkdir -p ../hb-icu/usr/lib32/pkgconfig; cd ../hb-icu
+ mv "$pkgdir"/usr/lib32/libharfbuzz-icu* ./usr/lib32
+ mv "$pkgdir"/usr/lib32/pkgconfig/harfbuzz-icu.pc ./usr/lib32/pkgconfig
+}
+
+package_lib32-harfbuzz-icu-git() {
+ pkgdesc="OpenType text shaping engine (32-bit, ICU integration)"
+ depends=(lib32-harfbuzz lib32-icu harfbuzz-icu)
+ provides=('lib32-harfbuzz-icu')
+ conflicts=('lib32-harfbuzz-icu')
+
+ mv hb-icu/* "$pkgdir"
+
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s harfbuzz-icu "$pkgdir/usr/share/licenses/lib32-harfbuzz-icu"
+}