summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Schoenick2018-12-18 13:58:01 -0800
committerJohn Schoenick2018-12-18 14:02:13 -0800
commitfcccb3cf65dd5bb1a6d8bb448fedd6ef89c12ade (patch)
tree8e450dac115798380c777b1b410d4ea2608894f1
parent7a43b3e0a48b73e7409de31a1ddc83a00f2f61ad (diff)
downloadaur-fcccb3cf65dd5bb1a6d8bb448fedd6ef89c12ade.tar.gz
Modified to lib32-heaptrack-git from upstream package
Forked from existing heaptrack-git on AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 38 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32fae39f0c5c..821ba273b905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Nov 29 17:25:36 UTC 2017
-pkgbase = heaptrack-git
+# Tue Dec 18 22:01:58 UTC 2018
+pkgbase = lib32-heaptrack-git
pkgdesc = A heap memory profiler
- pkgver = 682.c6ef628
+ pkgver = 812.f6a3479
pkgrel = 1
url = http://milianw.de/tag/heaptrack
arch = i686
@@ -10,17 +10,17 @@ pkgbase = heaptrack-git
license = APACHE
makedepends = git
makedepends = extra-cmake-modules
- makedepends = boost
makedepends = sparsehash
depends = kdiagram
depends = threadweaver
depends = kitemmodels
depends = kio
- depends = boost-libs
- provides = heaptrack
- conflicts = heaptrack
- source = git+git://anongit.kde.org/heaptrack
+ depends = heaptrack-git
+ depends = lib32-boost-libs
+ provides = lib32-heaptrack
+ conflicts = lib32-heaptrack
+ source = git+https://github.com/KDE/heaptrack.git
md5sums = SKIP
-pkgname = heaptrack-git
+pkgname = lib32-heaptrack-git
diff --git a/PKGBUILD b/PKGBUILD
index 09bd1ca49836..0abc564c66a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
-pkgname=heaptrack-git
-pkgver=682.c6ef628
+# Maintainer: John Schoenick <john@pointysoftware.net>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=lib32-heaptrack-git
+pkgver=812.f6a3479
pkgrel=1
pkgdesc="A heap memory profiler"
arch=('i686' 'x86_64')
url="http://milianw.de/tag/heaptrack"
license=('APACHE')
# dependencies with GUI enabled
-depends=('kdiagram' 'threadweaver' 'kitemmodels' 'kio' 'boost-libs')
-makedepends=('git' 'extra-cmake-modules' 'boost' 'sparsehash')
+depends=('kdiagram' 'threadweaver' 'kitemmodels' 'kio' 'heaptrack-git' 'lib32-boost-libs')
+makedepends=('git' 'extra-cmake-modules' 'sparsehash')
# minimal dependencies
#depends=('libunwind' 'boost-libs')
#makedepends=('git' 'cmake' 'boost')
-provides=('heaptrack')
-conflicts=('heaptrack')
-source=('git+git://anongit.kde.org/heaptrack')
+provides=('lib32-heaptrack')
+conflicts=('lib32-heaptrack')
+source=('git+https://github.com/KDE/heaptrack.git')
md5sums=('SKIP')
pkgver() {
@@ -29,10 +30,16 @@ prepare() {
build() {
cd "$srcdir/build"
- export CXXFLAGS="$CXXFLAGS -lboost_iostreams"
+ # Using the dependency on the main package for gui, just build libs and helpers to run against
+ # 32bit
+ export CXXFLAGS="$CXXFLAGS -lboost_iostreams -lboost_system -DBOOST_NO_CXX11_HDR_SYSTEM_ERROR"
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
cmake ../heaptrack \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ -DHEAPTRACK_BUILD_GUI=OFF \
+ -DLIB_SUFFIX=32 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
make
}
@@ -40,6 +47,17 @@ package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir" install
+
+ # Provided by full 64bit package that we depend on
+ rm -rf "$pkgdir"/usr/include
+
+ # No way to set an executable suffix through cmake, so rename here. The script does properly use
+ # the LIB_SUFFIX we provided above and will load the 32bit libraries.
+ for output in "$pkgdir"/usr/bin/*; do
+ [[ -f $output ]] || continue
+ msg2 "Renaming $(basename "$output") -> $(basename "${output}32")"
+ mv "$output" "${output}32"
+ done
}
# vim:set ts=2 sw=2 et: