summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-11 20:11:25 -0500
committerVincent Grande2021-01-11 20:11:25 -0500
commitd96e572ea2764bb180551882fc803ab93d4be79e (patch)
tree2bc9eae0b5caccd466f9943a4eb41a0d0b5b6870
downloadaur-d96e572ea2764bb180551882fc803ab93d4be79e.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f11d8a2b3275
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-kmod-git
+ pkgdesc = Linux kernel module handling
+ pkgver = 28
+ pkgrel = 1
+ url = https://www.kernel.org/pub/linux/utils/kernel/kmod
+ arch = x86_64
+ license = GPL2
+ makedepends = lib32-gcc-libs
+ makedepends = gcc-multilib
+ depends = lib32-zlib
+ depends = lib32-xz
+ provides = lib32-kmod
+ conflicts = lib32-kmod
+ options = !libtool
+ source = git+https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git
+ sha512sums = SKIP
+
+pkgname = lib32-kmod-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ba61e6f4836
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Eric Vidal <eric@obarun.org>
+# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
+#----------------
+# Website : https://git.kernel.org/?p=utils/kernel/kmod/kmod.git;a=summary
+#-----------------------------------------------------------------------------------------------
+
+pkgname=lib32-kmod-git
+pkgver=28
+pkgrel=1
+pkgdesc="Linux kernel module handling"
+arch=('x86_64')
+url="https://www.kernel.org/pub/linux/utils/kernel/kmod"
+license=('GPL2')
+source=("git+https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git")
+
+options=('!libtool')
+
+depends=(
+ 'lib32-zlib'
+ 'lib32-xz')
+
+makedepends=(
+ 'lib32-gcc-libs'
+ 'gcc-multilib')
+
+provides=(lib32-kmod)
+conflicts=(lib32-kmod)
+#-----------------------------------------------------------------------------------------------
+build() {
+
+ export CC="gcc -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd kmod
+
+ ./autogen.sh
+ ./configure \
+ --libdir=/usr/lib32 \
+ --sysconfdir=/etc \
+ --disable-tools \
+ --with-zlib \
+ --with-xz \
+ --disable-logging \
+ --disable-debug \
+ --disable-gtk-doc
+ make
+}
+
+package() {
+
+ cd kmod
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/{share,include,bin}
+}
+
+#-----------------------------------------------------------------------------------------------
+#validpgpkeys=('EAB33C9690013C733916AC839BA2A5A630CBEA53' # Lucas DeMarchi
+
+sha512sums=('SKIP')