summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-01-22 05:48:41 -0200
committerRafael Fontenelle2016-01-22 05:48:41 -0200
commit42649450c9c1f15803074fb4a2dff334b4a9c1eb (patch)
treeab84cb4453057a40bc8be35d460e0ea72555111c
downloadaur-42649450c9c1f15803074fb4a2dff334b4a9c1eb.tar.gz
First commit with 1.1.24
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caa494d35b26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jan 22 07:48:26 UTC 2016
+pkgbase = lib32-ldb
+ pkgdesc = A schema-less, ldap like, API and database
+ pkgver = 1.1.24
+ pkgrel = 1
+ url = http://ldb.samba.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lib32-python2
+ depends = lib32-talloc
+ depends = lib32-tevent
+ depends = lib32-tdb
+ depends = lib32-popt
+ optdepends = python2: for python bindings
+ source = http://samba.org/ftp/ldb/ldb-1.1.24.tar.gz
+ md5sums = 152f061422de5b90f8ce51e0ea316292
+
+pkgname = lib32-ldb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c7bda8be923
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+_name=ldb
+pkgname=lib32-$_name
+pkgver=1.1.24
+pkgrel=1
+pkgdesc="A schema-less, ldap like, API and database"
+arch=('i686' 'x86_64')
+url="http://ldb.samba.org/"
+source=(http://samba.org/ftp/${_name}/${_name}-${pkgver}.tar.gz)
+license=('GPL3')
+depends=('lib32-talloc' 'lib32-tevent' 'lib32-tdb' 'lib32-popt')
+makedepends=('lib32-python2')
+optdepends=('python2: for python bindings')
+md5sums=('152f061422de5b90f8ce51e0ea316292')
+
+build() {
+ cd "${_name}-${pkgver}"
+
+ # fix python2
+ sed -i -e "s|/usr/bin/env python$|/usr/bin/env python2|" buildtools/bin/waf
+
+ # set lib32 and python2 environment
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export PYTHON='/usr/bin/python2.7-32'
+ export PYTHON_CONFIG='/usr/bin/python2.7-32-config'
+
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --disable-rpath-install \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --libdir=/usr/lib32 \
+ --with-modulesdir=/usr/lib32/ldb/modules \
+ --with-privatelibdir=/usr/lib32/ldb
+ make
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+}