summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-08-26 08:38:31 -0400
committerAndrew Sun2018-08-26 08:38:31 -0400
commit79d0fdd0975263bc555ecf799dd258256cc64658 (patch)
tree2e0736ee40748fb718bd2a81f48f25309c994ceb
downloadaur-79d0fdd0975263bc555ecf799dd258256cc64658.tar.gz
add lib32-ldns (version 1.7.0)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rw-r--r--pc.patch60
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddc29175247d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-ldns
+ pkgdesc = Fast DNS library supporting recent RFCs (32-bit)
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://www.nlnetlabs.nl/projects/ldns/
+ arch = x86_64
+ license = custom:BSD
+ makedepends = lib32-libpcap
+ depends = lib32-openssl
+ depends = ldns
+ source = https://www.nlnetlabs.nl/downloads/ldns/ldns-1.7.0.tar.gz
+ source = pc.patch
+ sha256sums = c19f5b1b4fb374cfe34f4845ea11b1e0551ddc67803bd6ddd5d2a20f0997a6cc
+ sha256sums = 3586302eed28269c7fa6013785c0a017689aa9d4ff24ff8d7735fa23a3732cb7
+
+pkgname = lib32-ldns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18bb94ae643d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+_pkgname=ldns
+pkgname=lib32-${_pkgname}
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='Fast DNS library supporting recent RFCs (32-bit)'
+url='https://www.nlnetlabs.nl/projects/ldns/'
+license=('custom:BSD')
+arch=('x86_64')
+depends=('lib32-openssl' 'ldns')
+makedepends=('lib32-libpcap')
+source=("https://www.nlnetlabs.nl/downloads/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ 'pc.patch')
+sha256sums=('c19f5b1b4fb374cfe34f4845ea11b1e0551ddc67803bd6ddd5d2a20f0997a6cc'
+ '3586302eed28269c7fa6013785c0a017689aa9d4ff24ff8d7735fa23a3732cb7')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/pc.patch"
+}
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib32 \
+ --localstatedir=/var \
+ --disable-rpath \
+ --with-drill \
+ --without-examples
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+}
diff --git a/pc.patch b/pc.patch
new file mode 100644
index 000000000000..a37b1c376f38
--- /dev/null
+++ b/pc.patch
@@ -0,0 +1,60 @@
+From 2a38f26ed5695c3ad737de082b56a296240dd51a Mon Sep 17 00:00:00 2001
+From: Willem Toorop <willem@nlnetlabs.nl>
+Date: Thu, 19 Jan 2017 09:41:51 +0100
+Subject: bugfix #1209: make install ldns.pc file
+
+---
+ Changelog | 4 ++++
+ Makefile.in | 16 ++++++++++++++--
+ 2 files changed, 18 insertions(+), 2 deletions(-)
+
+diff --git a/Changelog b/Changelog
+index 0bd3658..efda95e 100644
+--- a/Changelog
++++ b/Changelog
+@@ -1,3 +1,7 @@
++1.7.1 ????-??-??
++ * bugfix #1209: make install ldns.pc file
++ Thanks Oleksandr Natalenko
++
+ 1.7.0 2016-12-20
+ * Fix lookup of relative names in ldns_resolver_search.
+ * bugfix #548: Double free for answers > 4096 in ldns_resolver_send_pkt
+diff --git a/Makefile.in b/Makefile.in
+index 04f683b..853777e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -308,9 +308,9 @@ clean-p5-dns-ldns: $(p5_dns_ldns_dir)/Makefile
+ test-p5-dns-ldns: $(p5_dns_ldns_dir)/Makefile
+ cd $(p5_dns_ldns_dir); $(MAKE) test
+
+-install: install-h install-lib @INSTALL_CONFIG@ install-manpages $(pyldns_inst) $(pyldnsx_inst) @INSTALL_P5_DNS_LDNS@ @INSTALL_DRILL@ @INSTALL_EXAMPLES@
++install: install-h install-lib install-pc @INSTALL_CONFIG@ install-manpages $(pyldns_inst) $(pyldnsx_inst) @INSTALL_P5_DNS_LDNS@ @INSTALL_DRILL@ @INSTALL_EXAMPLES@
+
+-uninstall: uninstall-manpages @UNINSTALL_CONFIG@ uninstall-h uninstall-lib $(pyldns_uninst) $(pyldnsx_uninst) @UNINSTALL_P5_DNS_LDNS@ @UNINSTALL_DRILL@ @UNINSTALL_EXAMPLES@
++uninstall: uninstall-manpages @UNINSTALL_CONFIG@ uninstall-h uninstall-lib uninstall-pc $(pyldns_uninst) $(pyldnsx_uninst) @UNINSTALL_P5_DNS_LDNS@ @UNINSTALL_DRILL@ @UNINSTALL_EXAMPLES@
+
+ destclean: uninstall
+
+@@ -355,6 +355,18 @@ uninstall-h:
+ test ! -d $(DESTDIR)$(includedir)/ldns || rmdir -p $(DESTDIR)$(includedir)/ldns || echo "ok, dir already gone"
+ exit 0
+
++packaging/libldns.pc: packaging/libldns.pc.in
++ ./config.status $@
++
++install-pc: packaging/libldns.pc
++ $(INSTALL) -m 644 packaging/libldns.pc $(DESTDIR)$(libdir)/pkgconfig/ldns.pc
++
++uninstall-pc:
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/pkgconfig/ldns.pc
++ test ! -d $(DESTDIR)$(libdir)/pkgconfig || rmdir -p $(DESTDIR)$(libdir)/pkgconfig || echo "ok, dir already gone"
++ test ! -d $(DESTDIR)$(libdir) || rmdir -p $(DESTDIR)$(libdir) || echo "ok, dir already gone"
++
++
+ install-lib: lib
+ $(INSTALL) -m 755 -d $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install cp libldns.la $(DESTDIR)$(libdir)
+--
+cgit v0.11.2
+