summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:56:35 +0300
committerarcan1s2015-06-08 19:56:35 +0300
commit43b87730280de913582aff78e30bc79feea40d21 (patch)
tree3f3a5923f70f8514bb322e5bd4885dd5edc95098
downloadaur-43b87730280de913582aff78e30bc79feea40d21.tar.gz
upload lib32-libarchive
-rw-r--r--.SRCINFO23
-rw-r--r--0001-mtree-fix-line-filename-length-calculation.patch28
-rw-r--r--PKGBUILD45
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ca61422d734
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lib32-libarchive
+ pkgdesc = library that can create and read several streaming archive formats (32 bit)
+ pkgver = 3.1.2
+ pkgrel = 2
+ url = http://libarchive.org
+ arch = x86_64
+ license = BSD
+ makedepends = gcc-multilib
+ makedepends = lib32-zlib
+ depends = lib32-acl
+ depends = lib32-bzip2
+ depends = lib32-expat
+ depends = lib32-lzo
+ depends = lib32-openssl
+ depends = lib32-xz
+ depends = libarchive
+ source = http://libarchive.org/downloads/libarchive-3.1.2.tar.gz
+ source = 0001-mtree-fix-line-filename-length-calculation.patch
+ md5sums = efad5a503f66329bb9d2f4308b5de98a
+ md5sums = 9727baf88b928417d5d1269891b1209a
+
+pkgname = lib32-libarchive
+
diff --git a/0001-mtree-fix-line-filename-length-calculation.patch b/0001-mtree-fix-line-filename-length-calculation.patch
new file mode 100644
index 000000000000..2299f5fba37e
--- /dev/null
+++ b/0001-mtree-fix-line-filename-length-calculation.patch
@@ -0,0 +1,28 @@
+From e65bf287f0133426b26611fe3e80b51267987106 Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Thu, 21 Feb 2013 19:01:06 -0500
+Subject: [PATCH] mtree: fix line filename length calculation. Fixes #301.
+ Signed-off-by: Andres Mejia <amejia004@gmail.com>
+
+---
+ libarchive/archive_write_set_format_mtree.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libarchive/archive_write_set_format_mtree.c b/libarchive/archive_write_set_format_mtree.c
+index 9c0613c..f37f723 100644
+--- a/libarchive/archive_write_set_format_mtree.c
++++ b/libarchive/archive_write_set_format_mtree.c
+@@ -1855,9 +1855,9 @@ mtree_entry_setup_filenames(struct archive_write *a, struct mtree_entry *file,
+ return (ret);
+ }
+
+- /* Make a basename from dirname and slash */
++ /* Make a basename from file->parentdir.s and slash */
+ *slash = '\0';
+- file->parentdir.length = slash - dirname;
++ file->parentdir.length = slash - file->parentdir.s;
+ archive_strcpy(&(file->basename), slash + 1);
+ return (ret);
+ }
+--
+1.8.1.4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26359c8f9036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Evgeniy Alekseev <arcanis.arch at gmail dot com>
+# Contributor: josephgbr <rafael.f.f1 at gmail dot com>
+
+_pkgname=libarchive
+pkgname=lib32-${_pkgname}
+pkgver=3.1.2
+pkgrel=2
+pkgdesc="library that can create and read several streaming archive formats (32 bit)"
+arch=('x86_64')
+url="http://libarchive.org"
+license=('BSD')
+depends=('lib32-acl' 'lib32-bzip2' 'lib32-expat' 'lib32-lzo' 'lib32-openssl' 'lib32-xz' "${_pkgname}")
+makedepends=('gcc-multilib' 'lib32-zlib')
+source=("http://libarchive.org/downloads/${_pkgname}-${pkgver}.tar.gz"
+ '0001-mtree-fix-line-filename-length-calculation.patch')
+md5sums=('efad5a503f66329bb9d2f4308b5de98a'
+ '9727baf88b928417d5d1269891b1209a')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+
+ # https://code.google.com/p/libarchive/issues/detail?id=301
+ # upstream commit e65bf287f0133426b26611fe3e80b51267987106
+ patch -Np1 -i "${srcdir}/0001-mtree-fix-line-filename-length-calculation.patch"
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd "${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --without-xml2 --libdir=/usr/lib32 \
+ --without-nettle --libexecdir="/usr/lib32/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+
+ install -dm755 "${pkgdir}"/usr/share/licenses
+ ln -s ${_pkgname} "${pkgdir}"/usr/share/licenses/${pkgname}
+}